RT3D Tutorials for GMS Users

By

T. P. Clement
(Pacific Northwest National Laboratory)

and

N.L. Jones
(Brigham Young University)
ACKNOWLEDGEMENTS

Funding Support
Funding support for RT3D code development research efforts was, in part, provided by the office of Technology Development, within the Department of Energy’s Office of Environmental Management, under the “Plume Focus Area” and the “Subsurface Contamination Focus Area.” The RT3D code was originally developed for the Remediation Technology Development Forum (RTDF) with the support from a DOE project that provided microbial characterization research and groundwater-modeling support to the bioremediation of chlorinated solvents consortium of the RTDF.

The Department of Defense Groundwater Modeling System (GMS) was developed by the Engineering Computer Graphics Laboratory of Brigham Young University in partnership with the U.S. Army Engineer Waterways Experiment Station.

Technical Support for RT3D Development Work
Dr. T. Prabhakar Clement, principal investigator of the RT3D project at PNNL, developed the initial concepts and design for the RT3D computer code. Dr. Clement also coded this version of RT3D (v1.0) from MT3D_DoD_1.5 (a public domain version of MT3D developed by Dr. Chunmiao Zheng at the University of Alabama). Several researchers at PNNL and other organizations provided technical support during various phases of this project: Dr. Yunwei Sun, Department of Chemical Engineering at Washington State University, provided debugging and coding support for developing a prototype version and a pre-processor MT2RT; Dr. Brian S. Hooker, Pacific Northwest National Laboratory, provided support for developing reaction expressions for hydrocarbon and chlorinated solvent degradation models; Christian D. Johnson, Pacific Northwest National Laboratory provided documentation and code testing support; Dr. James N. Petersen, Department of Chemical Engineering at Washington State University, provided debugging support for developing a prototype version and MT2RT; Dr. Chunmiao Zheng, Department of Geology, University of Alabama, provided support for solving MT3D (DoD_1.5) interfacing problems. In addition, Dr. Clement also benefited from helpful discussions with several other researchers-- suggestions of Dr. Ashok Chilakapati (at PNNL), Dr. Rodney Skeen (at PNNL), and Dr. Norman Jones (at BYU) are particularly acknowledged.

NOTICE:
The RT3D(v1.0) code is provided without any warranty. No author or distributor accepts any responsibility to anyone for the consequences of using it or for whether it serves any particular purpose.

For recent updates:
Visit:
http://www.ecgl.byu.edu/software/gms/gms.html
# TABLE OF CONTENTS

1 INTRODUCTION .................................................................................................................. 1-1
   1.1 OTHER DOCUMENTS ...................................................................................................... 1-2
   1.2 ORGANIZATION ............................................................................................................. 1-2
   1.3 DEMO VS. NORMAL MODE .............................................................................................. 1-2

2 INSTANTANEOUS AEROBIC DEGRADATION ........................................................................ 2-1
   2.1 DESCRIPTION OF PROBLEM ........................................................................................ 2-1
   2.2 DESCRIPTION OF REACTION ....................................................................................... 2-2
   2.3 LAUNCHING GMS ......................................................................................................... 2-2
   2.4 REQUIRED MODULES/INTERFACES ............................................................................ 2-3
   2.5 BUILDING THE MODFLOW MODEL .............................................................................. 2-3
      2.5.1 Conceptual Model Approach vs. Grid Approach ...................................................... 2-3
      2.5.2 Creating the Grid ................................................................................................... 2-4
      2.5.3 The Basic Package ................................................................................................. 2-4
      2.5.4 The BCF Package .................................................................................................. 2-5
      2.5.5 Defining the Spill Well .......................................................................................... 2-5
      2.5.6 Assigning the Head BC ........................................................................................ 2-6
      2.5.7 Running MODFLOW ............................................................................................. 2-6
      2.5.8 Viewing the Results .............................................................................................. 2-7
   2.6 BUILDING THE TRANSPORT MODEL .......................................................................... 2-7
      2.6.1 The BTN Package .................................................................................................. 2-8
      2.6.2 Assigning Concentrations to the Left Boundary ...................................................... 2-10
      2.6.3 The Advection Package ........................................................................................ 2-11
      2.6.4 The Dispersion Package ....................................................................................... 2-11
      2.6.5 The Source/Sink Mixing Package ......................................................................... 2-11
      2.6.6 The Chemical Reactions Package ........................................................................ 2-12
      2.6.7 Running RT3D ...................................................................................................... 2-12
      2.6.8 Viewing the Results .............................................................................................. 2-13
      2.6.9 Viewing a Film Loop Animation ......................................................................... 2-13
   2.7 CONCLUSION ................................................................................................................. 2-14

3 BTEX DEGRADATION WITH MULTIPLE ELECTRON ACCEPTORS .................................. 3-1
   3.1 DESCRIPTION OF THE REACTION MODEL ................................................................. 3-1
   3.2 DESCRIPTION OF PROBLEM ....................................................................................... 3-4
   3.3 LAUNCHING GMS ......................................................................................................... 3-4
   3.4 REQUIRED MODULES/INTERFACES ........................................................................... 3-5
   3.5 IMPORTING THE MODFLOW MODEL ......................................................................... 3-5
   3.6 BUILDING THE TRANSPORT MODEL .......................................................................... 3-5
   3.7 THE BTN PACKAGE .................................................................................................... 3-6
   3.8 ASSIGNING CONCENTRATIONS TO THE LEFT BOUNDARY ..................................... 3-8
   3.9 THE ADEPTION PACKAGE .......................................................................................... 3-8
   3.10 THE DISPERSION PACKAGE ....................................................................................... 3-9
   3.11 THE SOURCE/SINK MIXING PACKAGE ................................................................... 3-9
   3.12 THE CHEMICAL REACTION PACKAGE ..................................................................... 3-9
4 SEQUENTIAL ANAEROBIC DEGRADATION: PCE->TCE->DCE->VC ........................................................................... 4-1

4.1 DESCRIPTION OF PROBLEM ........................................................................................................... 4-1
4.2 DESCRIPTION OF REACTION .......................................................................................................... 4-2
4.3 LAUNCHING GMS ............................................................................................................................ 4-2
4.4 REQUIRED MODULES/INTERFACES ............................................................................................. 4-3
4.5 IMPORTING THE MODFLOW MODEL ............................................................................................ 4-3
4.6 BUILDING THE TRANSPORT MODEL ............................................................................................. 4-3
4.7 THE BTN PACKAGE ......................................................................................................................... 4-4
4.8 THE ADEPTION PACKAGE ................................................................................................................. 4-6
4.9 THE DISPERSION PACKAGE .............................................................................................................. 4-6
4.10 THE SOURCE/SINK MIXING PACKAGE .......................................................................................... 4-6
4.11 THE CHEMICAL REACTION PACKAGE ......................................................................................... 4-7
4.12 RUNNING RT3D ............................................................................................................................. 4-7
4.13 VIEWING THE RESULTS .................................................................................................................. 4-8
4.13.1 Creating a Time Series Plot ....................................................................................................... 4-9
4.13.2 Other Post-Processing Options ................................................................................................. 4-11
4.14 CONCLUSION ................................................................................................................................. 4-11

5 USER-DEFINED REACTIONS ........................................................................................................... 5-1

5.1 STEPS INVOLVED IN CREATING A USER-DEFINED REACTION ........................................................................ 5-1
5.2 REQUIRED BACKGROUND ................................................................................................................. 5-2
5.3 REACTION MODULE DESCRIPTION ............................................................................................... 5-2
5.4 CODING A NEW REACTION PACKAGE ............................................................................................ 5-4
5.4.1 Editing the Source Code of Reaction Module ............................................................................ 5-4
5.4.2 Compiling the Source Code ......................................................................................................... 5-6
5.5 TESTING AND DEBUGGING A NEW REACTION PACKAGE ..................................................................... 5-6
5.5.1 Running BATCHRXN .................................................................................................................. 5-7
5.5.2 Viewing the Results ..................................................................................................................... 5-8
5.6 SETTING UP THE RT3D SIMULATION ............................................................................................. 5-9
5.7 LAUNCHING GMS ............................................................................................................................. 5-9
5.8 REQUIRED MODULES/INTERFACES ............................................................................................... 5-10
5.9 IMPORTING THE MODFLOW MODEL ............................................................................................. 5-10
5.10 BUILDING THE TRANSPORT MODEL ............................................................................................. 5-10
5.10.1 The BTN Package ..................................................................................................................... 5-10
5.10.2 The Advection Package .............................................................................................................. 5-13
5.10.3 The Dispersion Package ............................................................................................................ 5-13
5.10.4 The Source/Sink Mixing Package ............................................................................................ 5-14
5.10.5 The Chemical Reaction Package ............................................................................................. 5-15
5.11 RUNNING RT3D ............................................................................................................................. 5-15
5.12 VIEWING THE RESULTS .................................................................................................................. 5-16
5.13 DEVELOPING A REUSABLE REACTION PACKAGE .......................................................................... 5-16
5.13.1 Editing the Source Code .......................................................................................................... 5-16
5.13.2 Compiling the Source Code ..................................................................................................... 5-17
5.14 MODIFYING THE TRANSPORT MODEL .......................................................................................... 5-18
5.14.1 The Chemical Reaction Package ............................................................................................. 5-18
5.14.2 Running RT3D .......................................................................................................................... 5-20
5.14.3 Viewing the Results .................................................................................................................. 5-21

5.15 CONCLUSION ................................................................................................................................. 5-14

5.5 TESTING AND DEBUGGING A NEW REACTION PACKAGE ..................................................................... 5-6
5.5.2 Viewing the Results ..................................................................................................................... 5-8
5.6 SETTING UP THE RT3D SIMULATION ............................................................................................. 5-9
5.7 LAUNCHING GMS ............................................................................................................................. 5-9
5.8 REQUIRED MODULES/INTERFACES ............................................................................................... 5-10
5.9 IMPORTING THE MODFLOW MODEL ............................................................................................. 5-10
5.10 BUILDING THE TRANSPORT MODEL ............................................................................................. 5-10
5.10.1 The BTN Package ..................................................................................................................... 5-10
5.10.2 The Advection Package .............................................................................................................. 5-13
5.10.3 The Dispersion Package ............................................................................................................ 5-13
5.10.4 The Source/Sink Mixing Package ............................................................................................ 5-14
5.10.5 The Chemical Reaction Package ............................................................................................. 5-15
5.11 RUNNING RT3D ............................................................................................................................. 5-15
5.12 VIEWING THE RESULTS .................................................................................................................. 5-16
5.13 DEVELOPING A REUSABLE REACTION PACKAGE .......................................................................... 5-16
5.13.1 Editing the Source Code .......................................................................................................... 5-16
5.13.2 Compiling the Source Code ..................................................................................................... 5-17
5.14 MODIFYING THE TRANSPORT MODEL .......................................................................................... 5-18
5.14.1 The Chemical Reaction Package ............................................................................................. 5-18
5.14.2 Running RT3D .......................................................................................................................... 5-20
5.14.3 Viewing the Results .................................................................................................................. 5-21
RT3D (Reactive Transport in 3-Dimensions) is a computer code that solves coupled partial differential equations that describe reactive-flow and transport of multiple mobile and/or immobile species in a three dimensional saturated porous media. RT3D was developed from the single-species transport code, MT3D (DoD_1.5, 1997 version). As with MT3D, RT3D also uses the USGS groundwater flow model MODFLOW for computing spatial and temporal variations in groundwater head distribution.

This report presents a set of tutorial problems that are designed to illustrate how RT3D simulations can be performed within the Department of Defense Groundwater Modeling System (GMS). GMS serves as a pre- and post-processing interface for RT3D. GMS can be used to define all the input files needed by RT3D code, and later the code can be launched from within GMS and run as a separate application. Once the RT3D simulation is completed, the solution can be imported to GMS for graphical post-processing.

RT3D v1.0 supports several reaction packages that can be used for simulating different types of reactive contaminants. Each of the tutorials, described below, provides training on a different RT3D reaction package. Each reaction package has different input requirements, and the tutorials are designed to describe these differences. Furthermore, the tutorials illustrate the various options available in GMS for graphical post-processing of RT3D results. Users are strongly encouraged to complete the tutorials before attempting to use RT3D and GMS on a routine basis.
1.1 Other Documents

There are several other documents describing GMS and RT3D. The GMS Reference Manual is a complete reference on GMS and includes a chapter describing the RT3D interface. The RT3D Reference Manual provides a detailed discussion of the equations, numerical methods, file formats, and other issues related to the RT3D model.

In addition to the GMS and RT3D manuals, the GMS Tutorials document contains a set of tutorials similar to the tutorials described in this document. These tutorials describe basic operation of GMS and include tutorials on MODFLOW, MT3D, MODPATH, FEMWATER, and SEEP2D. While it is not essential, it is recommended that the new user complete the MODFLOW and MT3D tutorials before beginning the RT3D tutorials contained in this document. The GMS Tutorials document does not contain RT3D tutorials. All RT3D tutorials are contained in this document.

1.2 Organization

The first tutorial (Chapter 2 - Instantaneous Aerobic Degradation) includes a description of how to build both the flow and the transport model within GMS. The remaining tutorials use a pre-defined flow model and only describe the construction of the transport model. Although the tutorials may be completed in any order, it is generally best to complete the first tutorial before attempting to complete any of the remaining tutorials.

1.3 Demo vs. Normal Mode

GMS utilizes a copy protection system wherein different components of the GMS interface may be licensed and activated separately. Modules and interfaces that have been licensed are enabled using the Register command in the File menu. The icons for the unlicensed modules or the menus for model interfaces are dimmed and cannot be accessed.

GMS provides two modes of operation: demo and normal. In normal mode, the modules and interfaces you have licensed are undimmed and fully functional and the items you have not licensed are dimmed and inaccessible. In demo mode, all modules and interfaces are undimmed and functional regardless of which items have been licensed. However, all of the print and save commands are disabled. While some of the tutorials in the GMS Tutorials document can be completed in demo mode, all of the tutorials in this document must be completed in normal mode.
This tutorial illustrates the steps involved in performing a reactive transport simulation using the RT3D model. RT3D is a modified version of MT3D that can be used to perform multi-species reactive transport modeling. Several types of reactions can be simulated with RT3D. The reaction simulated in this tutorial is instantaneous aerobic degradation of hydrocarbons.

2.1 Description of Problem

The problem we will be solving in this tutorial is shown in Figure 2.1. The site is a 510 m X 310 m section of a confined aquifer with a flow gradient from left to right. An underground storage tank is leaking fuel hydrocarbon contaminants at 2 m$^3$/day at the location shown. Concentration of hydrocarbons is 1000 mg/L and the spill may be assumed to be devoid of oxygen. Details of the aquifer hydrology and geometry are given below. Initial levels of hydrocarbon and oxygen in the aquifer are 0.0 and 9.0 mg/L, respectively. We will simulate a continuous spill event and compute the resulting hydrocarbon and oxygen contours after one year using instantaneous degradation kinetics.

The first part of the problem will be to compute a flow model of the site using MODFLOW. Using the flow field computed by MODFLOW, a reactive transport model will be then be defined using RT3D.
2.2 Description of Reaction

The reaction model we will be using simulates the instantaneous degradation of fuel hydrocarbons under aerobic conditions based on the following reaction (benzene basis):

\[ C_6H_6 + 7.5O_2 \rightarrow 6CO_2 + 3H_2O \] ................................. (2.1)

Therefore, the mass ratio of benzene to oxygen, \( F \), is 3.08 (i.e. 3.08 g of oxygen to 1 g of benzene). The instantaneous removal of either contaminant (H) or oxygen (O) is dictated by the following algorithm, where \( t \) refers to a particular time step:

\[ H(t + 1) = H(t) - O(t) / F \] and \( O(t + 1) = 0 \), when \( H(t) > O(t) / F \) .... (2.2)

\[ O(t + 1) = O(t) - H(t) \cdot F \] and \( H(t + 1) = 0 \), when \( O(t) > H(t) \cdot F \) .... (2.3)

Given this algorithm, either hydrocarbon or oxygen concentration in a given grid cell will be reduced to zero at each time step, depending on which component is stoichiometrically limiting in the prior time step.

2.3 Launching GMS

Before launching GMS, you should have installed GMS. If you have not yet installed GMS, please do so before continuing.

To launch the PC version of GMS:
Select the GMS shortcut from the Programs section in the Start menu (Windows 95, Windows NT 4.0), or double-click on the GMS icon in the GMS program group (Windows 3.1).

To launch the Unix version of GMS:

1. Bring up an xterm window.
2. Change to the directory containing the GMS executable.
3. Type gms at the command line.

### 2.4 Required Modules/Interfaces

This tutorial utilizes the following components of the GMS interface:

- The 3D Grid module
- The MODFLOW interface
- The RT3D interface

You can confirm whether each of these components has been enabled on your copy of GMS by selecting the Register command from the File menu. If you have licensed and enabled each of the listed items on your version of GMS, you can proceed to complete the tutorial in normal mode. If not, you will need to obtain an updated password or hardware lock before continuing.

### 2.5 Building the MODFLOW Model

The first part of the simulation is to build a MODFLOW flow model. In this case, a steady state flow model will be used with the transport simulation.

#### 2.5.1 Conceptual Model Approach vs. Grid Approach

In many cases, the most efficient way to create a MODFLOW simulation is to build a conceptual model of the site using the feature objects in the Map module. However, since this problem is a simple rectangular model, we will use the grid approach and edit values directly on the cells.
2.5.2 Creating the Grid

The first step in defining the MODFLOW simulation is to create a single layer grid.

1. Switch to the 3D Grid Module.
2. Select the Create Grid command in the Grids menu.
3. In the X dimension section, enter 510 for the length and 51 for the number of cells.
4. In the Y dimension section, enter 310 for the length and 31 for the number of cells.
5. In the Z dimension section, enter 1 for the number of cells (the length in Z does not matter).
6. Select the OK button.

At this point, you should see a grid appear.

2.5.3 The Basic Package

The next step is to define the data in the MODFLOW Basic Package. First, we will initialize the MODFLOW data.

1. Select the Basic Package command from the MODFLOW menu.
2. Select the New button.
3. In the Time Units section, select the Days option.

Next, we will define an initial condition of 100 m everywhere in the grid.

1. Select the Starting Heads button.
2. Select the Constant -> Grid button.
3. Select OK at the prompt.
4. Enter a value of 100.
5. Select the OK button.
6. Select the OK button to exit the Starting Heads dialog.
We need to change some values in the IBOUND array to designate the constant head boundaries. However, we will do this later by selecting the cells and using the Cell Attributes command. Thus, we are finished with this dialog.

Select the OK button to exit the Basic Package dialog.

### 2.5.4 The BCF Package

Next, we will define the data in the BCF package. First, we will select the steady state option.

1. Select the BCF Package command from the MODFLOW menu.
2. Select the Steady State option.

Next, we will define the layer data. Since we have one confined layer, the only value we need to enter is transmissivity.

1. In the Layer section, select the Confined option.
2. Select the Transmissivity button.
3. Select the Constant -> Grid button.
4. Enter a value of 500.
5. Select the OK button.
6. Select the OK button to exit the Transmissivity dialog.

The rest of the default options in the package should be sufficient.

Select the OK button to exit the BCF Package dialog.

### 2.5.5 Defining the Spill Well

The spill will be simulated by defining an injection well at the location of the spill with a small injection rate. During the transport simulation, a concentration will be assigned to the well. To define the well:

1. Select the Select Cell tool.
2. While watching the I,J fields in the Edit Window, locate and select the cell at I=16, J=16, K=1.
3. Select the Point Sources/Sinks command from the MODFLOW menu.
4. Select the Add button in the Well section.

5. Enter a value of 2.0 for Q.

6. Select the OK button to exit the Point Source/Sink dialog.

### 2.5.6 Assigning the Head BC

The final step before running MODFLOW is to assign the constant head boundary conditions on the left and right sides of the model. First, we will assign the head BC on the left side.

1. Select the Select J tool.

2. Select the leftmost column in the grid by clicking in any of the cells in the column.

3. Select the Cell Attributes command in the MODFLOW menu.

4. Enter -1 for the IBOUND value and leave the Starting Head at 100.0.

5. Select the OK button.

Next, we will assign the head BC on the right side.

1. Select the rightmost column in the grid by clicking in any of the cells in the column.

2. Select the Cell Attributes command in the MODFLOW menu.

3. Enter -1 for the IBOUND value and enter 99 for the Starting Head value.

4. Select the OK button.

### 2.5.7 Running MODFLOW

At this point, we are ready to save the model and run MODFLOW.

1. Select the Save Simulation command from the MODFLOW menu.

2. At the top of the dialog, enter "flowmod" for the prefix.

3. To the right of the prefix, select the Update button.

4. At the top of the dialog, select the File Browser button.
5. In the *Save File* dialog, locate and open the directory entitled `gms/tutorial/rt3d/btexins1`.

6. Select the *Save* button to exit the *Save File* dialog.

7. Select the *Save* button to save the files.

To run *MODFLOW*:

1. Select the *Run MODFLOW* command from the *MODFLOW* menu.

2. Select *OK* at the prompt.

3. When the simulation is finished, close the window and return to *GMS*.

### 2.5.8 Viewing the Results

Next, we will read in the computed head file and view the head contours to ensure the validity of the solution.

1. Select the *Data Browser* command from the *Data* menu.

2. Select the *Import* button on the left side of the dialog.

3. Select the *MODFLOW scalar file* option and select *OK*.

4. Select and open the file titled "flowmod.hed".

5. Select the *Done* button to exit the *Data Browser*.

To turn on the display of contours:

1. Select the *Display Options* command in the *Display* menu.

2. Turn on the *Layer Contours* option.

3. Select the *OK* button.

You should see a series of contours indicating a flow from left to right.

### 2.6 Building the Transport Model

Now that the flow model is established, the next step is to perform the *RT3D* simulation. For this part of the simulation, we will select the reaction, define the reaction data, define the supplemental layer data needed by *RT3D*, and assign concentrations to the well.
2.6.1 The BTN Package

The first step is to initialize the data in the Basic Transport Package. First, we will initialize the data, select RT3D as the transport model, and select the appropriate packages.

1. Select the Basic Transport Package command from the MT3D/RT3D menu.
2. Select the New button.
3. In the Units section, enter \( d \) for the time units, \( ft \) for the length units, and \( lb \) for the mass units.
4. Select the RT3D option.
5. Select the Packages button.
6. Select the Advection Package, the Source/Sink Mixing Package, the Dispersion Package, and the Chemical Reaction Package.
7. For the reaction type, select the Inst. Aerobic Deg. of BTEX option.
8. Select the OK button to exit the Packages dialog.

Note that in the Starting Concentration section of the dialog, the species associated with the reaction we are modeling are listed by name. The next step is to define the starting concentration for each of these species. By default all of the starting concentrations are zero. This is the correct concentration for BTEX. For oxygen, we will define an ambient concentration of 9.0 mg/L.

1. Select the Oxygen species in the list above the Starting Concentration button.
2. Select the Starting Concentration button.
3. Select the Constant -> Grid button.
4. Enter a value of 9.0 and select OK.
5. Select the OK button to exit the Starting Concentration dialog.

Next, we will define the layer parameters. The aquifer is a uniform horizontal aquifer with a top elevation of 10 m, a thickness of 10 m, and a porosity of 0.3.

1. Select the HTOP button.
2. Select the Constant -> Grid button.
3. Enter a value of 10 and select OK.
4. Select the OK button to exit the HTOP dialog.
5. Select the Thickness button.
6. Select the Constant -> Grid button.
7. Enter a value of 10 and select OK.
8. Select the OK button to exit the Thickness dialog.
9. Select the Porosity button.
10. Select the Constant -> Grid button.
11. Enter a value of 0.3 and select OK.
12. Select the OK button to exit the Porosity dialog.

Next, we will define the stress periods. Since the injection rate and the boundary conditions do not change, we will use a single stress period with a length of 730 days (two years).

1. Select the Stress Periods button.

Since there is already one stress period by default, we will simply change the length of the stress period

1. Enter a value of 730 for the Length.
2. Enter a value of 10 for the No. of time steps.
3. Select the OK button to exit the Stress Periods dialog.

Finally, we will define the output options. One binary solution file is created by RT3D for each of the species. By default, RT3D saves a solution at each transport step for each species. Since this results in large files containing more solutions than we need for the simple post-processing we intend to do, we will specify that a solution be saved every 73 days (every time step).

1. Select the Output Control button.
2. Select the Print at specified times button.
3. Select the Times button.
4. Select the Initialize Values button.
5. Enter 73.0 for the Initial time step size.
6. Enter 73.0 for the Maximum delta time step.
7. Enter 730.0 for the Maximum simulation time.
8. Select the OK button to exit the Variable Time Steps dialog.
9. Select the OK button to exit the Output Control dialog.

This completes the input for the Basic Transport package.

Select the OK button to exit the Basic Transport Package dialog.

2.6.2 Assigning Concentrations to the Left Boundary

The left boundary of the model is a constant head boundary. Since the head at the left boundary is greater than the head at the right boundary, the left boundary acts as a source and water enters the model from the left. Thus, we must define the concentrations of our species at the left boundary. Otherwise, the water entering the model will have the default concentration (zero) for each of the species. This is often true for most species, but there are exceptions. For our model, the incoming fluid should have an ambient oxygen concentration of 9.0 mg/L. The oxygen concentration can be assigned one of two ways:

1. The cells at the boundary can be marked as specified concentration cells by changing the ICBUND value at the cells to –1.
2. The concentration of the incoming fluid at the boundary can be defined using the Source/Sink Mixing package.

The first method requires the fewest number of steps to set up. As long as the boundary acts as a source throughout the simulation, either of these approaches will achieve the same result. However, if the boundary acts as a sink during any part of the simulation, the second option should be used. With the second option, if the boundary switches to a sink due to changing heads in the interior of the model, the concentrations at the cells would be computed by RT3D. With the first option, the concentrations at the cells are fixed, regardless of the flow direction.

For our problem, the flow field is steady state and we know that the boundary acts as a source. Thus, we will use the first option. To mark the cells as specified concentration cells:

1. Select the Select Cell tool.
2. Select the cells on the left boundary by dragging a box that just surrounds the cells.

3. Select the Cell Attributes command in the MT3D/RT3D menu.

4. Change the ICBUND value to –1.

5. Select the OK button.

Note that we do not need to assign a value, since the values are already assigned via the starting concentration arrays.

2.6.3 The Advection Package

The next step is to initialize the data for the Advection package. We will be using the MOC method. Since this is the default method, no changes need to be made.

2.6.4 The Dispersion Package

Next, we will enter the data for the Dispersion package. The aquifer has a longitudinal dispersivity of 10.0 m and a transverse dispersivity of 3.0 m. The vertical dispersivity is assumed equal to the longitudinal dispersivity.

1. Select the Dispersion Package command in the MT3D/RT3D menu.

2. Select the Longitudinal Dispersivity button.

3. Select the Constant -> Grid button.

4. Enter a value of 10.0 and select OK.

5. Select the OK button to exit the Longitudinal Dispersivity dialog.

6. Enter a value of 0.3 for the Ratio of the transverse dispersivity to long. dispersivity value.

7. Select the OK button to exit the Dispersion Package dialog.

2.6.5 The Source/Sink Mixing Package

Next, we will initialize the Source/Sink Mixing package and define the concentration at the spill location.

1. Select the Source/Sink Mixing Package command in the MT3D/RT3D menu.
2. In the *Initialize Point Source/Sinks from MODFLOW* section in the lower right corner of the dialog, select the *Well* button.

At this point, the concentrations at the well can be edited directly from this dialog or by exiting the dialog and selecting the cell containing the well and selecting the *Point Source/Sink* command. Since there is only one well, the easiest approach in this case is to edit the concentration in this dialog. We will assign a concentration of 1000 mg/L for the BTEX and leave the oxygen at the default value of 0.0.

1. Using the horizontal scroll bar below the spreadsheet section, scroll over until the BTEX column is visible.

2. Change the BTEX value to 1000.0.

3. Select the *OK* button to exit the *Source/Sink Mixing Package* dialog.

### 2.6.6 The Chemical Reactions Package

The next step is to initialize the data for the Chemical Reactions package. In this case, the default values are adequate and no changes are necessary.

### 2.6.7 Running RT3D

At this point, we are ready to save the model and run *RT3D*.

1. Select the *Save Simulation* command from the *MT3D/RT3D* menu.

2. At the top of the dialog, enter "btexmod" for the prefix.

3. To the right of the prefix, select the *Update* button.

4. At the top of the dialog, select the *File Browser* button.

5. In the *Save File* dialog, locate and open the directory entitled `gms/tutorial/rt3d/btexins1/`.

6. Select the *Save* button to exit the *Save File* dialog.

7. Select the *OK* button to save the files.

To run *RT3D*:

1. Select the *Run RT3D* command from the *MT3D/RT3D* menu.

2. Select *OK* at the prompt.
3. When the simulation is finished, return to GMS.

2.6.8 Viewing the Results

Now, we will read in the concentration files and view the results. A separate concentration file is created by RT3D for each of the species. A data set super file containing the names of the concentration files is also created. All of the concentration files can be read at once simply by opening this file.

1. Select the Open command from the File menu.

2. Select and open the file titled "btexmod.dss".

3. Select the Data Browser command in the Data menu.

Note that all of the species names are listed in the Data Browser. Each species is saved to a separate data set file. The *.dss file is a "data set super file" which contains the names of each of the species files. By reading in the *.dss file, we effectively read in all of the files at once.

First, we will view the Oxygen solution at 730 days.

1. Select the Oxygen data set.

2. Scroll down and select the time step at t=730 days.

3. Select the Done button to exit the Data Browser.

To get a better plot of the concentration contours:

1. Select the Contour Options command in the Data menu.

2. Select the Color fill between contours option.

3. Select the Color Ramp Opt button.

4. Select the Show color legend option.

5. Select the OK button to exit the Color Ramp Options dialog.

6. Select the OK button to exit the Contour Options dialog.

Next, we will view the BTEX solution at 730 days.

1. Select the Data Browser command from the Data menu.

2. Select the BTEX data set.
3. Scroll down and select the time step at \( t = 730 \) days.

4. Select the \textit{Done} button to exit the \textit{Data Browser}.

2.6.9 \textbf{Viewing a Film Loop Animation}

The most effective post-processing tool for transient data is a film loop animation. We will set up a film loop showing the fate of the BTEX through the entire duration of the simulation.

Before setting up the film loop, we will turn off the color legend.

1. Select the \textit{Color Ramp Opts} command in the \textit{Data} menu.

2. Turn off the \textit{Show color legend} option.

3. Select the \textit{OK} button.

To set up the film loop:

1. Select the \textit{Film Loop} command in the \textit{Data} menu.

2. Select the \textit{Setup} button.

3. Turn on the \textit{Display clock} option.

4. Select the \textit{OK} button.

When the hourglass cursor disappears:

1. Select the \textit{Play} button to begin the animation.

2. After viewing the animation, select the \textit{Stop} button to stop the animation.

3. Select the \textit{Step} button to move the animation one frame at a time.

4. You may wish to experiment with some of the other playback controls. When you are finished, select the \textit{Done} button to exit the \textit{Film Loop} dialog.

2.7 \textbf{Conclusion}

This concludes the \textit{Instantaneous Aerobic Degradation} tutorial. If you wish to exit \textit{GMS} at this time:

1. Select the \textit{Exit} command from the \textit{File} menu.
2. Select the OK button at the prompt.
CHAPTER 3

BTEX Degradation with Multiple Electron Acceptors

This tutorial illustrates the steps involved in using GMS and RT3D to model BTEX degradation using a multiple electron acceptor model. Since the flow model used in this simulation is similar to the flow model used in Chapter 2 Instantaneous Aerobic Degradation, the steps involved in building the flow model will not be described in this tutorial. A pre-defined version of the flow model will be used.

3.1 Description of the Reaction Model

The reaction we will be simulating is biodegradation of BTEX compounds via different aerobic/anaerobic pathways using multiple electron acceptors. Five different processes, considered in this model, include Aerobic Respiration (AR), Denitrification (DN), Iron (III) Reduction (IR), Sulfate Reduction (SR), and Methanogenesis (MG). All of these bio/chemical reactions are assumed to occur at the aqueous phase, mediated the existing subsurface microbes, and are expected to happen in the following sequence:

\[ \text{AR} \rightarrow \text{DN} \rightarrow \text{IR} \rightarrow \text{SR} \rightarrow \text{MG} \]

The following reaction kinetic framework is used to model the degradation of rate of hydrocarbon via different electron acceptor pathways:
where \( r_{HC,O_2} \) is the rate at which hydrocarbon is destroyed by utilizing oxygen, \( r_{HC,NO_3} \) is the rate at which hydrocarbon is destroyed by utilizing Nitrate, \( r_{HC,Fe^{2+}} \) is the rate at which hydrocarbon is destroyed by producing Fe\(^{2+}\) (or utilizing Fe\(^{3+}\)), \( r_{HC,SO_4} \) is the rate at which hydrocarbon is destroyed by utilizing sulfate, \( r_{HC,CH_4} \) is the rate at which hydrocarbon is destroyed by producing methane, \([O_2]\) is the oxygen concentration \([ML^{-3}]\), \( k_{O_2} \) is the first-order rate constant \([T^{-1}]\), \( K_{O_2} \) is the Monod half saturation constant \([ML^{-3}]\) (by setting all the half-saturation constants to a small value we can simulate zero-order dependency with respect electron donor and hence a first-order degradation model with respect to hydrocarbon; the default values simulate this option), and \( K_{i,o_2} \) is the oxygen inhibition constant \([ML^{-3}]\) (by setting all inhibition constants to a small value we can force the reactions to occur in a sequential fashion; the default values simulate this process). Similar nomenclature is used to identify other Monod constants and inhibition coefficients.

Since the concentrations of Fe\(^{3+}\) and CO\(_2\) are not readily measurable under normal field conditions, these terms were replaced with the “assimilative capacity” for iron reduction and methanogenesis, defined as:
\[ [\text{Fe}^{3+}] = [\text{Fe}^{2+}_{\text{max}}] - [\text{Fe}^{2+}] \] ................................. (3.7)

\[ [\text{MC}] = [\text{CO}_2] = [\text{CH}_4_{\text{max}}] - [\text{CH}_4] \] ................................. (3.8)

where \([\text{Fe}^{2+}_{\text{max}}]\) and \([\text{CH}_4_{\text{max}}]\) are the maximum possible aquifer levels of these species that represent the aquifer’s maximum capacity for iron reduction and methanogenesis. Note, the concentration of CO\(_2\) used here is the CO\(_2\) evolved while the hydrocarbon is destroyed via methanogenesis which may be thought of as the “Methanogenic Capacity” (MC) of the aquifer. Using these relations, iron (III) reduction and methanogenesis processes may be related back to measurable Fe\(^{2+}\) and CH\(_4\) concentration levels.

The total rate of hydrocarbon destruction, via all the above described processes, is the sum of each individual rates and is given as:

\[
\frac{\text{d}[\text{HC}]}{\text{dt}} = r_{\text{HC,CO}_2} + r_{\text{HC,NO}_3} + r_{\text{HC,Fe}^{2+}} + r_{\text{HC,SO}_4} + r_{\text{HC,CH}_4} \] ................................. (3.9)

Rates of electron acceptor utilization are given as the corresponding rate of hydrocarbon destruction multiplied by the appropriate yield coefficient (Y):

\[
\frac{\text{d}[\text{O}_2]}{\text{dt}} = Y_{\text{O}_2/\text{HC}} r_{\text{HC,CO}_2} \] ............................................. (3.10)

\[
\frac{\text{d}[\text{NO}_3]}{\text{dt}} = Y_{\text{NO}_3/\text{HC}} r_{\text{HC,NO}_3} \] ............................................. (3.11)

\[
\frac{\text{d}[\text{Fe}^{2+}]}{\text{dt}} = -Y_{\text{Fe}^{2+/\text{HC}}} r_{\text{HC,Fe}^{2+}} \] ............................................. (3.12)

\[
\frac{\text{d}[\text{SO}_4]}{\text{dt}} = Y_{\text{SO}_4/\text{HC}} r_{\text{HC,SO}_4} \] ............................................. (3.13)

\[
\frac{\text{d}[\text{CH}_4]}{\text{dt}} = -Y_{\text{CH}_4/\text{HC}} r_{\text{HC,CH}_4} \] ............................................. (3.14)

The yield values (the mass ratio of electron acceptors removed or metabolic byproducts produced to total BTEX degraded) are: \(Y_{\text{O}_2/\text{HC}} = 3.14\), \(Y_{\text{NO}_3/\text{HC}} = 4.9\), \(Y_{\text{Fe}^{2+/\text{HC}}} = 21.8\), \(Y_{\text{SO}_4/\text{HC}} = 4.7\), and \(Y_{\text{CH}_4/\text{HC}} = 0.78\).
3.2 Description of Problem

The problem we will be solving in this tutorial is similar to the problem described in the first tutorial (Figure 2.1). The site is a 510 m X 310 m section of a confined aquifer with a flow gradient from left to right. An underground storage tank is leaking fuel hydrocarbon contaminants at 2 m$^3$/day at the location shown. Concentration of BTEX is 1000 mg/L. Initial levels of hydrocarbon, oxygen, nitrate, Fe$^{2+}$, sulfate, and methane in the aquifer are assumed to be: 0.0, 4.0, 20.0, 0.0, 10.0, and 0.0 mg/L, respectively. The reaction constants to be used are as follows:

<table>
<thead>
<tr>
<th>Constant</th>
<th>Value</th>
</tr>
</thead>
</table>
| Max Fe$^{2+}$ | 25.0 mg/L |<br>
| Max Methane | 30.0 mg/L |<br>
| $k_{HC,O_2}$ | 0.1 day$^{-1}$ |<br>
| $k_{HC,N_2O}$ | 0.008 day$^{-1}$ |<br>
| $k_{HC,NO_3}$ | 0.0005 day$^{-1}$ |<br>
| $k_{HC,SO_4}$ | 0.00025 day$^{-1}$ |<br>
| $k_{HC,CH_4}$ | 0.0001 day$^{-1}$ |<br>

Values of all inhibition coefficients are assumed to be 0.01 mg/L and all Monod constants are assumed to 0.5 mg/L. The yield values are same as those described in the previous section.

The first part of the problem will be to import a previously computed MODFLOW flow model of the site. Using this flow field, a reactive transport model will be then be defined using RT3D.

3.3 Launching GMS

Before launching GMS, you should have installed GMS. If you have not yet installed GMS, please do so before continuing.

To launch the PC version of GMS:

Select the GMS shortcut from the Programs section in the Start menu (Windows 95, Windows NT 4.0), or double-click on the GMS icon in the GMS program group (Windows 3.1).

To launch the Unix version of GMS:

1. Bring up an xterm window.
2. Change to the directory containing the GMS executable.
3. Type gms at the command line.
3.4 Required Modules/Interfaces

This tutorial utilizes the following components of the GMS interface:

- The 3D Grid module
- The MODFLOW interface
- The RT3D interface

You can confirm whether each of these components has been enabled on your copy of GMS by selecting the Register command from the File menu. If you have licensed and enabled each of the listed items on your version of GMS, you can proceed to complete the tutorial in normal mode. If not, you will need to obtain an updated password or hardware lock before continuing.

3.5 Importing the MODFLOW Model

The first part of the simulation is to import the MODFLOW flow model. A steady state flow model has been previously computed and is supplied with the tutorial files.

1. Switch to the 3D Grid Module
2. Select the Read Simulation command in the MODFLOW menu.
3. In the Open dialog, locate and open the file entitled gms/tutorial/rt3d/flowmod/flowmod1.mfs.

At this point, you should see a grid appear.

3.6 Building the Transport Model

Now that the flow model is imported, the next step is to perform the RT3D simulation. For this part of the simulation, we will select the reaction, define the reaction data, define the supplemental layer data needed by RT3D, and assign concentrations to the well.
3.7 The BTN Package

The first step is to initialize the data in the Basic Transport Package. First, we will initialize the data, select RT3D as the transport model, and select the appropriate packages.

1. Select the Basic Transport Package command from the MT3D/RT3D menu.
2. Select the New button.
3. In the Units section, enter $d$ for the time units, $ft$ for the length units, and $lb$ for the mass units.
4. Select the RT3D option.
5. Select the Packages button.
6. Select the Advection Package, the Source/Sink Mixing Package, the Dispersion Package, and the Chemical Reaction Package.
7. For the reaction type, select the Kinetic-Limited Deg. of BTEX w/ MEA option.
8. Select the OK button to exit the Packages dialog.

Note that in the Starting Concentration section of the dialog, the species associated with the reaction we are modeling are listed by name. The next step is to define the starting concentration for each of these species. The default starting concentration is zero. We will use the default value for BTEX, Fe$^{2+}$, and methane, but we use non-zero values for oxygen (4.0 mg/L), nitrate (20.0 mg/L), and sulfate (10.0 mg/L).

1. Select oxygen from the list of species.
2. Select the Starting Conc.'s button.
3. Select the Constant -> Grid button.
4. Enter a value of 4.0.
5. Select the OK button.
6. Select the OK button to exit the Starting Concentration dialog.
7. Repeat these steps to enter a starting value of 20.0 for the nitrate and 10.0 for the sulfate.
Next, we will define the layer parameters. The aquifer is a uniform horizontal aquifer with a top elevation of 10 m, a thickness of 10 m, and a porosity of 0.3.

1. Select the HTOP button.
2. Select the Constant -> Grid button.
3. Enter a value of 10 and select OK.
4. Select the OK button to exit the HTOP dialog.
5. Select the Thickness button.
6. Select the Constant -> Grid button.
7. Enter a value of 10 and select OK.
8. Select the OK button to exit the Thickness dialog.
9. Select the Porosity button.
10. Select the Constant -> Grid button.
11. Enter a value of 0.3 and select OK.
12. Select the OK button to exit the Porosity dialog.

Next, we will define the stress periods. Since the injection rate and the boundary conditions do not change, we will use a single stress period with a length of 730 days (two years).

1. Select the Stress Periods button.
2. Enter a value of 730 for the Length.
3. Enter a value of 10 for the No. of time steps.
4. Select the OK button to exit the Stress Periods dialog.

Finally, we will define the output options. One binary solution file is created by RT3D for each of the species. By default, RT3D saves a solution at each transport step for each species. Since this results in large files containing more solutions than we need for the simple post-processing we intend to do, we will specify that a solution be saved every 73 days (every time step).

1. Select the Output Control button.
2. Select the Print at specified times button.
3. Select the *Times* button.

4. Select the *Initialize Values* button.

5. Enter 73.0 for the *Initial time step size*.

6. Enter 73.0 for the *Maximum delta time step*.

7. Enter 730.0 for the *Maximum simulation time*.

8. Select the *OK* button to exit the *Variable Time Steps* dialog.

9. Select the *OK* button to exit the *Output Control* dialog.

This completes the input for the Basic Transport package.

Select the *OK* button to exit the *Basic Transport Package* dialog.

### 3.8 Assigning Concentrations to the Left Boundary

The left boundary of the model is a constant head boundary. Since the head at the left boundary is greater than the head at the right boundary, the left boundary acts as a source and water enters the model from the left. Thus, we must define the concentrations of our species at the left boundary. The simplest way to do this is to mark the cells as specified concentration cells.

1. Select the *Select Cell* tool.

2. Select the cells on the left boundary by dragging a box that just surrounds the cells.

3. Select the *Cell Attributes* command in the *MT3D/RT3D* menu.

4. Change the *ICBUND* value to –1.

5. Select the *OK* button.

### 3.9 The Advection Package

The next step is to initialize the data for the Advection package. Select the upstream finite-difference method and accept the default settings.
3.10 The Dispersion Package

Next, we will enter the data for the Dispersion package. The aquifer has a longitudinal dispersivity of 10.0 m and a transverse (horizontal) dispersivity of 3.0 m. The vertical dispersivity is assumed equal to the longitudinal dispersivity.

1. Select the Dispersion Package command in the MT3D/RT3D menu.
2. Select the Longitudinal Dispersivity button.
3. Select the Constant -> Grid button.
4. Enter a value of 10.0 and select OK.
5. Select the OK button to exit the Longitudinal Dispersivity dialog.
6. Enter a value of 0.3 for the Ratio of the transverse dispersivity to long. dispersivity value.
7. Select the OK button to exit the Dispersion Package dialog.

3.11 The Source/Sink Mixing Package

Next, we will initialize the Source/Sink Mixing package and define the concentration at the spill location. We will assign a concentration of 1000 mg/L for BTEX and leave other electron acceptor concentrations at the default value of 0.0.

1. Select the Source/Sink Mixing Package command in the MT3D/RT3D menu.
2. In the Initialize Point Source/Sinks from MODFLOW section in the lower right corner of the dialog, select the Well button.
3. Using the horizontal scroll bar below the spreadsheet section, scroll over until the BTEX column is visible.
4. Change the BTEX value to 1000.0.
5. Select the OK button to exit the Source/Sink Mixing Package dialog.

3.12 The Chemical Reaction Package

Next, we will initialize the chemical reaction package and define appropriate reaction rate constants.
1. Select the Chemical Reaction Package command in the MT3D/RT3D menu.

2. In the Reaction Parameters section, click on the Max Fe\(^{2+}\) item and set its value to 25.0.

3. Likewise, set the value of Max Methane to 30.0.

4. Set the value of \(k_{HC,\text{O}_2}\) to 0.1.

5. Set the value of \(k_{HC,\text{NO}_3}\) to 0.008.

6. Set the value of \(k_{HC,\text{Fe}^{3+}}\) to 0.0005.

7. Set the value of \(k_{HC,\text{SO}_4}\) to 0.00025.

8. Set the value of \(k_{HC,\text{CH}_4}\) to 0.0001.

The monod constants, inhibition coefficients, and yield values will all be left at the default values.

Select the OK button.

### 3.13 Running RT3D

At this point, we are ready to save the model and run RT3D.

1. Select the Save Simulation command from the MT3D/RT3D menu.

2. At the top of the dialog, enter "btmod" for the prefix.

3. To the right of the prefix, select the Update button.

4. At the top of the dialog, select the File Browser button.

5. In the Save File dialog, locate and open the directory entitled gms/tutorial/rt3d/btexkin/.

6. Select the Save button to exit the Save File dialog.

7. Select the OK button to save the files.

To run RT3D:

1. Select the Run RT3D command from the MT3D/RT3D menu.

2. Select OK at the prompt.
3. When the simulation is finished, close the window and return to GMS.

### 3.14 Viewing the Results

Now, we will read in the concentration files and view the results.

1. Select the Open command from the File menu.
2. Select and open the file titled "btmod.dss".
3. Select the Data Browser command in the Data menu.

Note that all of the species names are listed in the Data Browser. Each species is saved to a separate data set file. The *.dss file is a "data set super file" which contains the names of each of the species files. By reading in the *.dss file, we effectively read in all of the files at once.

First, we will view the BTEX solution at 730 days.

1. Select the BTEX data set.
2. Scroll down and select the time step at t=730 days.
3. Select the Done button to exit the Data Browser.

To display the concentration contours:

1. Select the Display Opts command in the Display menu.
2. Turn off the Cells option.
3. Turn on the Grid shell option.
4. Turn on the Layer contours option.
5. Select the OK button.

### 3.14.1 Overlaying Contours

Next, we will view concentration contours for the other species. When working with multiple species, it is often convenient to overlay contours of one species on top of contours from another species. As an example, we will overlay the contours of the other species on top of the BTEX contours. To do this, we must save a copy of the BTEX contours to a DXF file, read the file in, and display the BTEX contours in the background.
Before saving the dxf file, we will turn off most of the display options other than the contours.

1. Select the *Display Opts* command in the *Display* menu.

2. Turn off all of the options but the *Layer contours* option.

3. Select the *OK* button.

To save the contours to a DXF file:

1. Select the *Switch to General Mode* command from the *View* menu.
   
   *GMS* requires that the *General Mode* be active when exporting DXF files.

2. Select the *Export* command in the *File* menu.

3. Select the *DXF file* option.

4. Select the *OK* button.

5. If necessary, path to the *gms/tutorials/rt3d/btexkin* directory.

6. Enter "btexcont.dxf" for the file name.

7. Select the *Save* button.

Before reading the contours back in, we will reset the display options and view the oxygen solution at 730 days.

1. Select the *Switch to Ortho Mode* command from the *View* menu.

2. Select the *Display Opts* command in the *Display* menu.

3. Turn on the *Grid Shell* option.

4. Select the *OK* button.

5. Select the *Data Browser* command from the *Data* menu.

6. Select the *oxygen* data set.

7. Scroll down and select the time step at t=730 days.

8. Select the *Done* button to exit the *Data Browser*.

9. Select the *Contour Options* command in the *Data* menu.

10. Select the *Use color ramp* option.
11. Select the *Color Ramp Opts* button.

12. Select the *Show color legend* option.

13. Select the *OK* button to exit the *Color Ramp Options* dialog.

14. Select the *OK* button to exit the *Contour Options* dialog.

Now we are ready to import the BTEX contours.

1. Switch to the *Map* module.

2. Select the *Import* command in the *DXF* menu.

3. Select and open the "btexcont.dxf" file.

Next, we will view the nitrate solution at 730 days.

1. Switch to the *3D Grid* module.

2. Select the *Data Browser* command from the *Data* menu.

3. Select the *nitrate* data set.

4. Scroll down and select the time step at t=730 days.

5. Select the *Done* button to exit the *Data Browser*.

Finally, we will view the Fe$^{2+}$ solution at 730 days.

1. Select the *Data Browser* command from the *Data* menu.

2. Select the *Fe$^{2+}$* data set.

3. Scroll down and select the time step at t=730 days.

4. Select the *Done* button to exit the *Data Browser*.

### 3.14.2 Other Post-Processing Options

At this point, you may wish to experiment with the other post-processing options, including film loop animation.
This concludes the tutorial: \textit{BTEX Degradation with Multiple Electron Acceptor}. If you wish to exit \textit{GMS} at this time:

1. Select the \textit{Exit} command from the \textit{File} menu.

2. Select the \textit{OK} button at the prompt.
CHAPTER 4

Sequential Anaerobic Degradation: PCE→TCE→DCE→VC

This tutorial illustrates the steps involved in modeling sequential anaerobic degradation of PCE using the RT3D model. Since the flow model used in this simulation is similar to the flow model used in Chapter 2 Instantaneous Aerobic Degradation, the steps involved in building the flow model will not be described in this tutorial. A pre-defined version of the flow model will be used.

4.1 Description of Problem

The problem we will be solving in this tutorial is similar to the problem described in the first tutorial (Figure 2.1). The site is a 510 m X 310 m section of a confined aquifer with a flow gradient from left to right. An underground storage tank is leaking fuel hydrocarbon contaminants at 2 m³/day at the location shown. Concentration of PCE is 1000 mg/L (note, this high hypothetical concentration was selected to simulate a plume (with considerable PCE mass) with relatively low injection flow rate). Details of the aquifer hydrology and geometry are shown in Figure 2.1. Initial levels of PCE and its degradation products in the aquifer are assumed to be 0.0 mg/L. We will simulate a continuous spill event and compute the resulting PCE, TCE, DCE and VC contours after three years.

The first part of the problem will be to import a previously computed MODFLOW flow model of the site. Using this flow field, a reactive transport model will be then be defined using RT3D.
4.2 Description of Reaction

The reaction we will be simulating is anaerobic PCE dechlorination with sequential, first-order, degradation kinetics. Degradation of PCE all the way to VC is assumed to anaerobically favorable and the degradation kinetics are assumed to be first-order in nature.

\[
PCE \rightarrow TCE \rightarrow DCE \rightarrow VC \ ................................................................. \ (4.1)
\]

The following set of equations describes the reaction kinetics framework.

\[
r_{PCE} = -k_1 [PCE] \ .............................................................................................. \ (4.2)
\]

\[
r_{TCE} = k_2 Y_{TCE/PCE} [PCE] - k_2 [TCE] ........................................................................ \ (4.3)
\]

\[
r_{DCE} = k_3 Y_{DCE/TCE} [TCE] - k_3 [DCE] ........................................................................ \ (4.4)
\]

\[
r_{DCE} = k_4 Y_{VC/DCE} [DCE] - k_4 [VC] ........................................................................ \ (4.5)
\]

Kinetic Constants (to be input by the user):

<table>
<thead>
<tr>
<th>Constant</th>
<th>Value</th>
<th>Designation</th>
</tr>
</thead>
<tbody>
<tr>
<td>(k_1)</td>
<td>0.005 day(^{-1})</td>
<td>PCE anaerobic constant</td>
</tr>
<tr>
<td>(k_2)</td>
<td>0.003 day(^{-1})</td>
<td>TCE anaerobic constant</td>
</tr>
<tr>
<td>(k_3)</td>
<td>0.002 day(^{-1})</td>
<td>DCE anaerobic constant</td>
</tr>
<tr>
<td>(k_4)</td>
<td>0.001 day(^{-1})</td>
<td>VC anaerobic constant</td>
</tr>
</tbody>
</table>

The following constants (yields in mg/mg basis) are fixed internally:

<table>
<thead>
<tr>
<th>Constant</th>
<th>Value</th>
<th>Designation</th>
</tr>
</thead>
<tbody>
<tr>
<td>(Y_{TCE/PCE})</td>
<td>0.7920</td>
<td>TCE:PCE stoichiometric yield</td>
</tr>
<tr>
<td>(Y_{DCE/TCE})</td>
<td>0.7377</td>
<td>DCE:TCE stoichiometric yield</td>
</tr>
<tr>
<td>(Y_{VC/DCE})</td>
<td>0.6445</td>
<td>VC:DCE stoichiometric yield</td>
</tr>
</tbody>
</table>

4.3 Launching GMS

Before launching GMS, you should have installed GMS. If you have not yet installed GMS, please do so before continuing.

To launch the PC version of GMS:

Select the GMS shortcut from the Programs section in the Start menu (Windows 95, Windows NT 4.0), or double-click on the GMS icon in the GMS program group (Windows 3.1).

To launch the Unix version of GMS:

1. Bring up an xterm window.
2. Change to the directory containing the GMS executable.

3. Type `gms` at the command line.

### 4.4 Required Modules/Interfaces

This tutorial utilizes the following components of the GMS interface:

- The 3D Grid module
- The MODFLOW interface
- The RT3D interface

You can confirm whether each of these components has been enabled on your copy of GMS by selecting the Register command from the File menu. If you have licensed and enabled each of the listed items on your version of GMS, you can proceed to complete the tutorial in normal mode. If not, you will need to obtain an updated password or hardware lock before continuing.

### 4.5 Importing the MODFLOW Model

The first part of the simulation is to import the MODFLOW flow model. A steady state flow model has been previously computed and is supplied with the tutorial files.

1. Switch to the 3D Grid Module

2. Select the Read Simulation command in the MODFLOW menu.

3. In the Open dialog, locate and open the file entitled `gms/tutorial/rt3d/flowmod/flowmod1.mfs`.

At this point, you should see a grid appear.

### 4.6 Building the Transport Model

Now that the flow model is imported, the next step is to perform the RT3D simulation. For this part of the simulation, we will select the reaction, define the reaction data, define the supplemental layer data needed by RT3D, and assign concentrations to the well.
4.7 The BTN Package

The first step is to initialize the data in the Basic Transport Package. First, we will initialize the data, select RT3D as the transport model, and select the appropriate packages.

1. Select the Basic Transport Package command from the MT3D/RT3D menu.
2. Select the New button.
3. In the Units section, enter d for the time units, ft for the length units, and lb for the mass units.
4. Select the RT3D option.
5. Select the Packages button.
6. Select the Advection Package, the Source/Sink Mixing Package, the Dispersion Package, and the Chemical Reaction Package.
7. For the reaction type, select the Sequential Decay Reactions option.
8. Select the OK button to exit the Packages dialog.

Note that in the Starting Concentration section of the dialog, the species associated with the reaction we are modeling are listed by name. The next step is to define the starting concentration for each of these species. By default all of the starting concentrations are zero. Since the aquifer is assumed to be initially clean, we will simply accept the default values for starting concentrations.

Next, we will define the layer parameters. The aquifer is a uniform horizontal aquifer with a top elevation of 10 m, a thickness of 10 m, and a porosity of 0.3.

1. Select the HTOP button.
2. Select the Constant -> Grid button.
3. Enter a value of 10 and select OK.
4. Select the OK button to exit the HTOP dialog.
5. Select the Thickness button.
6. Select the Constant -> Grid button.
7. Enter a value of 10 and select OK.
8. Select the OK button to exit the Thickness dialog.

9. Select the Porosity button.

10. Select the Constant -> Grid button.

11. Enter a value of 0.3 and select OK.

12. Select the OK button to exit the Porosity dialog.

Next, we will define the stress periods. Since the injection rate and the boundary conditions do not change, we will use a single stress period with a length of 730 days (two years).

5. Select the Stress Periods button.

6. Enter a value of 730 for the Length.

7. Enter a value of 10 for the No. of time steps.

8. Select the OK button to exit the Stress Periods dialog.

Finally, we will define the output options. One binary solution file is created by RT3D for each of the species. By default, RT3D saves a solution at each transport step for each species. Since this results in large files containing more solutions than we need for the simple post-processing we intend to do, we will specify that a solution be saved every 73 days (every time step).

1. Select the Output Control button.

2. Select the Print at specified times button.

3. Select the Times button.

4. Select the Initialize Values button.

5. Enter 73.0 for the Initial time step size.

6. Enter 73.0 for the Maximum delta time step.

7. Enter 730.0 for the Maximum simulation time.

8. Select the OK button to exit the Variable Time Steps dialog.

9. Select the OK button to exit the Output Control dialog.

This completes the input for the Basic Transport package.

Select the OK button to exit the Basic Transport Package dialog.
4.8 The Advection Package

The next step is to initialize the data for the Advection package. Select the upstream finite-difference method and accept the default settings.

4.9 The Dispersion Package

Next, we will enter the data for the Dispersion package. The aquifer has a longitudinal dispersivity of 10.0 m and a transverse (horizontal) dispersivity of 3.0 m. The vertical dispersivity is assumed equal to the longitudinal dispersivity.

1. Select the Dispersion Package command in the MT3D/RT3D menu.
2. Select the Longitudinal Dispersivity button.
3. Select the Constant -> Grid button.
4. Enter a value of 10.0 and select OK.
5. Select the OK button to exit the Longitudinal Dispersivity dialog.
6. Enter a value of 0.3 for the Ratio of the transverse dispersivity to long. dispersivity value.
7. Select the OK button to exit the Dispersion Package dialog.

4.10 The Source/Sink Mixing Package

Next, we will initialize the Source/Sink Mixing package and define the concentration at the spill location. We will assign a concentration of 1000 mg/L for PCE and leave TCE, DCE, and VC concentrations at the default value of 0.0.

1. Select the Source/Sink Mixing Package command in the MT3D/RT3D menu.
2. In the Initialize Point Source/Sinks from MODFLOW section in the lower right corner of the dialog, select the Well button.
3. Using the horizontal scroll bar below the spreadsheet section, scroll over until the PCE column is visible.
4. Change the PCE value to 1000.0.
5. Select the OK button to exit the Source/Sink Mixing Package dialog.
4.11 The Chemical Reaction Package

Next, we will initialize the chemical reaction package and define appropriate reaction rate constants.

1. Select the Chemical Reaction Package command in the MT3D/RT3D menu.

2. In the Reaction Parameters section, click on $K_{\text{pce}}$ and set its value to 0.005.

3. Likewise, set the value of $K_{\text{tce}}$ to 0.003.

4. Set the value of $K_{\text{dce}}$ to 0.002.

5. Set the value of $K_{\text{vc}}$ to 0.001.

6. Select the OK button.

4.12 Running RT3D

At this point, we are ready to save the model and run RT3D.

1. Select the Save Simulation command from the MT3D/RT3D menu.

2. At the top of the dialog, enter "rtmod" for the prefix.

3. To the right of the prefix, select the Update button.

4. At the top of the dialog, select the File Browser button.

5. In the Save File dialog, locate and open the directory entitled gms/tutorial/rt3d/pce1/.

6. Select the Save button to exit the Save File dialog.

7. Select the OK button to save the files.

To run RT3D:

1. Select the Run RT3D command from the MT3D/RT3D menu.

2. Select OK at the prompt.

3. When the simulation is finished, close the window and return to GMS.
4.13 Viewing the Results

Now, we will read in the concentration files and view the results.

1. Select the *Open* command from the *File* menu.
2. Select and open the file titled "rtmod.dss".
3. Select the *Data Browser* command in the *Data* menu.

First, we will view the PCE solution at 730 days.

1. Select the *PCE* data set.
2. Scroll down and select the time step at t=730 days.
3. Select the *Done* button to exit the *Data Browser*.

To view the concentration contours:

1. Select the *Display Options* command in the *Display* menu.
2. Turn off the *Cells* option.
3. Turn on the *Grid shell* option.
4. Turn on the *Layer contours* option.
5. Select the *OK* button.
6. Select the *Contour Opt* command in the *Data* menu.
7. Select the *Color fill between contours* option.
8. Select the *Color Ramp Opt* button.
9. Select the *Show color legend* option.
10. Select the *OK* button to exit the *Color Ramp Options* dialog.
11. Select the *OK* button to exit the *Contour Options* dialog.

Next, we will view the TCE solution at 730 days.

1. Select the *Data Browser* command from the *Data* menu.
2. Select the *TCE* data set.
3. Scroll down and select the time step at t=730 days.
4. Select the *Done* button to exit the *Data Browser*.

Next, we will view the DCE solution at 730 days.

1. Select the *Data Browser* command from the *Data* menu.
2. Select the *DCE* data set.
3. Scroll down and select the time step at *t*=730 days.
4. Select the *Done* button to exit the *Data Browser*.

Next, we will view the VC solution at 730 days.

1. Select the *Data Browser* command from the *Data* menu.
2. Select the *VC* data set.
3. Scroll down and select the time step at *t*=730 days.
4. Select the *Done* button to exit the *Data Browser*.

### 4.13.1 Creating a Time Series Plot

Another highly effective tool for viewing *RT3D* solutions is a time series plot. A time series plot is used to display the variation of concentration vs. time for one or more species at a particular point in the model. Time series plots are set up using an observation coverage in the *Map* module.

First, we will define an observation coverage.

1. Switch to the *Map* module.
2. Select the *Coverages* command in the *Feature Objects* menu.
3. In the *Attribute Set* section, select the *Observation* option.
4. Select the *Options* button to the right of the *Observation* option.
5. Turn on the *Interpolate in layer only* option.
6. Select the *OK* button to exit the *Observation Coverage Options* dialog.
7. Select the *OK* button to exit the *Coverages* dialog.

Next, we will create an observation point.
1. Select the *Create Point* tool.

2. Click on a point somewhere in the grid downgradient of the well.

The final step is to create a time series plot.

1. Select the *Obs. Plot Options* command in the *Display* menu.

2. Select the *New* button to create a new plot.

3. Change the type of the plot to *Time series*.

4. Select the *OK* button.

5. Select the *Open/Close Plot Window* command in the *Display* menu.

**Moving the Observation Point**

At this point, you should see a plot of the active data set (VC) vs. time. The plot can easily be changed to display the variation in the data set at a different location.

1. Select the *Select Point/Node* tool.

2. Click on the observation point and drag it to a new location (Note: you may need to reposition or resize the *Plot Window* to see the observation point).

**Plotting Multiple Data Sets**

By default, only the active data set is plotted. For *RT3D* solutions, it is often useful to include all of the species in the plot. This can be accomplished as follows:

1. Select the *Obs. Plot Options* command in the *Display* menu.

2. Select the *Options* button.

3. Select the *Use selected data set* option.

4. In the list of data sets, select each of the data sets that are not displayed and turn on the *Display* toggle.

5. Select the *OK* button to exit the *Time Series Plot Options* dialog.

6. Turn on the *Curve legend* option (this will help us distinguish which data set goes with which curve).
7. Select the OK button to exit the Observation Plot Options dialog.

8. Reselect the observation point if necessary.

Once again, note that you can move the point anywhere in the grid and the plot is updated.

### 4.13.2 Other Post-Processing Options

At this point, you may wish to experiment with the other post-processing options, including film loop animation.

### 4.14 Conclusion

This concludes the tutorial: Sequential Anaerobic Degradation: PCE->TCE->DCE->VC. If you wish to exit GMS at this time:

1. Select the Exit command from the File menu.

2. Select the OK button at the prompt.
The objective of this chapter is to describe the steps involved in developing a user defined reaction module for simulating reactions that cannot be simulated using a pre-defined RT3D-reaction package. Once developed, users can distribute the new reaction package to other interested modelers for applying the reaction model at different sites (i.e., it can be treated like a pre-defined reaction package).

5.1 Steps Involved in Creating a User-Defined Reaction

User-defined reaction packages can be created using one of two approaches: the dynamically linked library (DLL) option or the linked subroutine option. With the DLL option, the subroutine for the reaction package is compiled as a stand-alone DLL. The DLL is then copied to the same directory as the RT3D executable and the DLL is automatically launched by RT3D when RT3D is executed. The DLL can be recompiled or a new DLL can be used simply by copying the new DLL to the same directory as the RT3D executable and naming it appropriately. The RT3D executable does not need to be recompiled.

With the linked subroutine option, the code for the new reaction subroutine is compiled and linked with the rest of the RT3D source code (or the RT3D library made for a specific computer platform). In other words, the RT3D executable must be recompiled each time the reaction package is modified.
Because of the portability of the developed reaction package, the DLL option is the more convenient of the two options. However, the DLL option is only available on the Windows 95/NT platform. It is not available on Unix.

This tutorial describes the DLL approach for creating user-defined reaction packages. Special instructions for the Unix platform are contained in Section 5.16 on page 5-22.

### 5.2 Required Background

As a reaction module developer, you are considered an advanced user of the RT3D code. The required background is as follows:

- Should have a basic understanding of the functionality of RT3D code and understand how different types of components (mobile and immobile) are mathematically described within RT3D-modeling framework.

- Should be familiar with GMS v2.1 and be able to create MODFLOW and RT3D input files with little effort.

- Should be familiar with the data structure of RT3D input files such as BTN, SSM, and RCT files.

- Should have a basic understanding of the FORTRAN language, and have access to Microsoft FORTRAN Power Station or DEC Visual FORTRAN compiler (or a UNIX system based FORTRAN 90 compiler).

- Should have some background/understanding of biochemical reaction kinetics. Note inappropriate kinetic expressions and/or kinetic constants may lead to unpredictable code behavior.

- Should be familiar with contaminant transport equations, and coupled nonlinear differential equations.

### 5.3 Reaction Module Description

The flow and transport model we will be developing in this tutorial exercise is identical to the one described in the tutorial entitled: Sequential Anaerobic Degradation: PCE->TCE->DCE->VC.

Assuming first-order sequential biodegradation kinetics, the transformation of PCE and its decay products, along with its transport, can be predicted using the following set of partial differential equations:
where \([\text{PCE}],[\text{TCE}],[\text{DCE}],[\text{VC}]\) are the concentrations of the respective contaminants in mg/L; \(K_{\text{PCE}}, K_{\text{TCE}}, K_{\text{DCE}},\text{ and } K_{\text{VC}}\) are first-order degradation rates, \(R_{\text{P}}, R_{\text{T}}, R_{\text{D}}, \text{ and } R_{\text{V}}\) are retardation coefficients; \(Y_{\text{TCE/PCE}}, Y_{\text{DCE/TCE}}, \text{ and } Y_{\text{VC/DCE}}\) are yield coefficients whose values can be computed from stoichiometric relations as 0.79, 0.74, and 0.64, respectively [for example, based the chemical reaction stochiometry, one mole of PCE will yield one mole of TCE (or 165.8 grams of PCE will yield 131.36 grams of TCE), therefore the yield value for \(Y_{\text{TCE/PCE}} = 131.36/165.8 = 0.79\)].

The kinetic model formulation presented assumes that the biological degradation reactions occur only in the liquid phase (a more conservative assumption).

Using the reaction operator-split strategy, the biological reaction kinetics can be separated from the transport equations and assembled together into a set differential equations:

\[
\begin{align*}
\frac{d[\text{PCE}]}{dt} &= -\frac{K_{\text{PCE}}[\text{PCE}]}{R_{\text{P}}} \\
\frac{d[\text{TCE}]}{dt} &= \frac{Y_{\text{TCE/PCE}}K_{\text{PCE}}[\text{PCE}] - K_{\text{TCE}}[\text{TCE}]}{R_{\text{T}}} \\
\frac{d[\text{DCE}]}{dt} &= \frac{Y_{\text{DCE/TCE}}K_{\text{TCE}}[\text{TCE}] - K_{\text{DCE}}[\text{DCE}]}{R_{\text{D}}} \\
\frac{d[\text{VC}]}{dt} &= \frac{Y_{\text{VC/DCE}}K_{\text{DCE}}[\text{DCE}] - K_{\text{VC}}[\text{VC}]}{R_{\text{V}}}
\end{align*}
\]

The above set of coupled differential equations describes the kinetics of PCE degradation and its daughter products.
5.4 Coding a New Reaction Package

Three different methods can be used for coding a new user-defined reaction package. Each method treats the reaction parameter information (values of $K_{\text{tot}}$, $K_{\text{per}}$, etc.) in a different fashion.

1. In the first method, all reaction parameter values are explicitly assigned within the reaction module prior to compilation. This is not an efficient method since it requires recompilation of the reaction routine whenever a reaction parameter value is modified. However, this method is recommended for testing a new reaction module with the BATCHRXN utility.

2. In the second method, all the reaction parameter values are spatially constant but are assigned/modified externally, as input data, via the *.RCT file (to run RT3D) or batch.in file (to run BATCHRXN).

3. In the third method, some or all of the reaction parameters are treated as spatially variable (i.e. a different value may be assigned to each cell). The parameter values should be externally assigned/modified as input data, via the *.RCT file. This option should be used with caution because it may require significant computer resources, both execution time and memory!

We will first use method #1 in this tutorial; later, we will modify the code to demonstrate method #3.

5.4.1 Editing the Source Code of Reaction Module

The complete listing of the FORTRAN subroutine (using method-#1) that describes the PCE degradation reactions is given below:

```fortran
SUBROUTINE rxns(ncomp,nvrxndata,j,i,k,y,dydt,
& poros,rhob,reta,rc,nlay,nrow,ncol,vrc)
  c ***** Block 1: Comments block ******
c23456789012345678901234567890123456789012
  c ncomp - Total number of components
c  nvrxndata - Total number of variable reaction parameters to be input via RCT file
c  J, I, K - node location (used if reaction parameters are spatially variable)
c  y - Concentration value of all component at the node [array variable y(ncomp)]
c  dydt - Computed RHS of your differential equation [array variable dydt(ncomp)]
c  poros - porosity of the node
c  reta - Retardation factor [array variable reta(mcomp)]
c  rhob - bulk density of the node
c  rc - Stores spatially constant reaction parameters (up to 100 values)
c  nlay, nrow, ncol - Grid size (used only for dimensioning purposes)
c  vrc - Array variable that stores spatially variable reaction parameters
  c ***** End of Block 1 ******
c  c *** Block 2: Please do not modify this standard interface block ***
!M$ATTRIBUTES DLLEXPORT :: rxns
IMPLICIT NONE
INTEGER ncol,nrow,nlay
INTEGER ncomp,nvrxndata,j,i,k
INTEGER First_time
DATA First_time/1/
DOUBLE PRECISION y,dydt,poros,rhob,reta
DOUBLE PRECISION rc,vrc
DIMENSION y(ncomp),dydt(ncomp),rc(50)
DIMENSION vrc(ncol,nrow,nlay,nvrxndata),reta(50)
```
C ****** End of block 2 *******

C *** Block 3: Declare your problem-specific new variables here ***
C
INTEGER
DOUBLE PRECISION pce, tce, dce, vc, kpce, ktce, kdce, kvc
DOUBLE PRECISION ytcepce, ydcetce, yvcdce
C ***** End of Block 3 ******

C *** Block 4: Initialize reaction parameters here, if required ***
IF (First_time .EQ. 1) THEN
  kpce = 0.005  !PCE first-order degradation rate
  ktce = 0.003  !TCE first-order degradation rate
  kdce = 0.002  !DCE first-order degradation rate
  kvc = 0.001  !VC first-order degradation rate
  ytcepce = 131.36/165.8
  ydcetce = 96.9/131.36
  yvcdce = 62.45/96.9
  First_time = 0 !reset First_time to skip this block later
END IF
C ***** End of Block 4 ******

C *** Block 5: Definition of other variable names ***
pce = y(1)
tce = y(2)
dce = y(3)
vc = y(4)
C ***** End of Block 5 ******

C *** Block 6: Definition of Differential Equations ***
dydt(1) = -kpce*pce/reta(1)
dydt(2) = (-ktce*tce + kpce*pce*ytcepce)/reta(2)
dydt(3) = (-kdce*dce + ktce*tce*ydcetce)/reta(3)
dydt(4) = (-kvc*vc + kdce*dce*yvcdce)/reta(4)
C ***** End of Block 6 ******
RETURN
END

Note that the reaction subroutine listed above is organized into the following six distinct blocks of FORTRAN code:

1. The comment block

   This block contains a definition for all the variables that are passed into the rxns routine from the RT3D main program.

2. The interfacing block

   This block contains FORTRAN statements that define the type of passed variables. This block should not be altered under any circumstances.

3. The local variable definition block

   This block is used define all the new local variables that are used exclusively in the rxns subroutine.

4. The reaction parameter initialization block

   This block is used to specify values for all the reaction parameters (such as K_{PCE}, K_{TCE}, etc.). Note that this initialization block is executed only when the subroutine is called for the first time.

5. Variables naming block
This block is typically used to transfer certain passed variables into meaningful names (this is required for code clarity purposes only).

6. The differential equations block

This block is used to describe the PCE degradation reaction equations in FORTRAN language.

The FORTRAN subroutine presented above is provided with the GMS files in the following location:

\[ gms\tutorial\rt3d\userdef\rxns_1.f \]

You may wish to open and view this file using your favorite ASCII editor (such as Notepad or WordPad).

### 5.4.2 Compiling the Source Code

Now the reaction module is ready for compilation. To create a dynamic link library (RXNS.DLL file), open a DOS window and go to the subdirectory where RXNS.F was saved and type the following command (this assumes that you have previously installed the Microsoft FORTRAN Power Station or DVF compiler):

\[ fl32 /LD rxns_1.f \]

At this stage, the compiler will display all the syntax errors. If no changes have been made to the code, there shouldn’t be any errors. If there are errors, fix them and recompile the code. After a successful compilation step, the compiler will create a DLL file (named as RXNS_1.DLL). Use the following DOS command to rename the DLL as RXNS.DLL.

\[ RENAME RXNS_1.DLL RXNS.DLL \]

If you do not have access to a FORTRAN compiler but wish to continue with the tutorial, you can find a pre-compiled copy of rxns_1.dll in the tutorial/rt3d/userdef/ directory.

### 5.5 Testing and Debugging a New Reaction Package

After creating a new reaction package, it is always a good practice to test its response in a batch mode (i.e. how the reactions would behave in a batch reactor). For this purpose, we have developed a utility called BATCHRXN. This debugging tool can read the reaction information in a RXNS.DLL file and simulate its behavior in a batch mode.
To use BATCRXN, it is recommended that the user define all the kinetic reaction parameters within the rxns subroutine (i.e. using method-#1). This is because the BATCRXN code will not read information from RT3D input files, including the RCT file. Therefore, a new reaction module should always be developed in a format similar to Method-#1 (or #2) and later, if required, the kinetic parameters can be moved into a RCT file to run RT3D simulations.

In addition to testing the new reaction module using BATCRXN, it is also a good practice to test the transport problem using RT3D in single-species tracer mode. Once a reaction package is tested using BATCRXN, the DLL can be used with RT3D to run a full-fledged RT3D simulation.

### 5.5.1 Running BATCRXN

Whenever BATCRXN is executed, the code searches for a RXNS.DLL file in the local subdirectory. Thus, you should copy the RXNS.DLL file to the GMS directory (this is where the BATCRXN.EXE and RT3D.EXE files are stored by default). While developing a new reaction module, always keep the source code (rxns*.f) in a local project directory, and rename and copy the DLL as RXNS.DLL into the GMS directory.

After you have copied the RXNS.DLL file into the GMS directory, open a DOS window and run the BATCRXN code from your project subdirectory. The code will query for several input data. The queries and the appropriate responses for this example problem are given below:

```
Input-> ncomp, no_of_timesteps, delt
Format-> INTEGER, INTEGER, REAL
4 100 10.
Input-> Initial Values of y(i)
ncomp lines - One REAL entry per line
100. *Initial PCE concentration in this case*
0.0 *Initial TCE concentration in this case*
0.0 *Initial DCE concentration in this case*
0.0 *Initial VC concentration in this case*
Do you want to change default atol & rtol: y/n
Default values are:- atol=1.0e-10 & rtol=1.0e-9
n
Input-> ncrxndata (number of reaction parameters)
Format-> INTEGER
0
```

You can also store these responses in a data file (say, batch.in) and use the command “batcrxrn < batch.in” to automatically answer all the BATCRXN queries. Here is an example batch.in file:

```
4 1000 1.
100.
0.
0.
0.
y
1.0e-11 1.0e-10
1.0e-11 1.0e-10
1.0e-11 1.0e-10
```
Note in the second case atol and rtol values are not initialized as default values, instead are set explicitly by the user.

### 5.5.2 Viewing the Results

After reading the input, BATCHRXN will execute and create an output file called batchrxn.out. The output file will contain a set of white-space separated ASCII data in column format (written using the Format statement 21E15.5). For our example problem, five columns are output: Time, specie-1 (PCE), specie-2 (TCE), specie-3 (DCE), and specie-4 (VC). Use any spreadsheet software such as Excel to plot and analyze this output data. The BATCHRXN output results for the example problem are shown in Figure 5.1.

![Graph](attachment:image.png)

*Figure 5.1 Sample Output from the BATCHRXN Code for the Sample Problem.*

The results of a BATCHRXN run should be used to:

1. Debug errors in reaction expressions.

2. Check whether the reaction expressions and parameter values are reasonable (if available, microcosm or batch reactor data may be used to verify this).

3. Select appropriate values for numerical parameters atol (absolute tolerance) and rtol (relative tolerance).

The parameters atol and rtol are used by the differential equations solver to control convergence error while solving the reaction model. The differential equation solver will attempt to control a vector $e = e(i)$, which defines estimated local error (or convergence level) in a variable $y(i)$, according to the
inequality: max-norm of \([e(i)/ewt(i)]\) is less than or equal to 1.0, where \(ewt(i)\) is a vector of positive error weights and is computed using the formula: \(ewt(i) = rtol(i)*abs(y(i)) + atol(i)\).

We recommend the following rule of thumb to set atol and rtol values. If \(m\) is the number of significant digits required in the solution component \(y(i)\), set \(RTOL(i) = 10^{-m+1}\) and set \(ATOL(i)\) to a small value at which the absolute value of \(y(i)\) is essentially insignificant.

Note: since transport is not solved while executing batchrxn, all the retardation factors in the array reta() are automatically set to 1.0 with the DLL. However, if the same DLL is used with RT3D, appropriate species retardation factors will be transferred through the reta() array.

5.6 Setting up the RT3D Simulation

At this stage, we are ready to run a RT3D simulation using the newly developed reaction package. To do this, will define the transport model and enter the input data using the GMS interface. Once the model is built, we will save it to a set of RT3D input files and launch RT3D. When the user-defined reaction package option is selected, RT3D automatically launches the RXNS.DLL subroutine to solve the reaction terms.

5.7 Launching GMS

Before launching GMS, you should have installed GMS. If you have not yet installed GMS, please do so before continuing.

To launch the PC version of GMS:

Select the GMS shortcut from the Programs section in the Start menu (Windows 95, Windows NT 4.0), or double-click on the GMS icon in the GMS program group (Windows 3.1).

To launch the Unix version of GMS:

1. Bring up an xterm window.
2. Change to the directory containing the GMS executable.
3. Type gms at the command line.
5.8 Required Modules/Interfaces

This tutorial utilizes the following components of the GMS interface:

- The 3D Grid module
- The MODFLOW interface
- The RT3D interface

You can confirm whether each of these components has been enabled on your copy of GMS by selecting the Register command from the File menu. If you have licensed and enabled each of the listed items on your version of GMS, you can proceed to complete the tutorial in normal mode. If not, you will need to obtain an updated password or hardware lock before continuing.

5.9 Importing the MODFLOW Model

The first part of the simulation is to import the MODFLOW flow model. A steady state flow model has been previously computed and is supplied with the tutorial files.

1. Switch to the 3D Grid Module.
2. Select the Read Simulation command in the MODFLOW menu.
3. In the Open dialog, locate and open the file entitled gms/tutorial/rt3d/flowmod/flowmod1.mfs.

At this point, you should see a grid appear.

5.10 Building the Transport Model

Now that the flow model is established, the next step is to perform the RT3D simulation. For this part of the simulation, we will select the user-defined reaction option, define and initialize appropriate species and reaction parameters, and assign concentrations to the well.

5.10.1 The BTN Package

The first step is to modify the data in the Basic Transport Package. First, we will select the user-defined reaction module option and name appropriate species and initialize their concentrations.
1. Select the Basic Transport Package command from the MT3D/RT3D menu.

2. Select the New button.

3. In the Units section, enter $d$ for the time units, $ft$ for the length units, and $lb$ for the mass units.

4. In the Model section, select the RT3D option.

5. Select the Packages button.

6. Select the Advection Package, the Source/Sink Mixing Package, the Dispersion Package, and the Chemical Reaction Package.

7. For the reaction type, select the User-Defined Reaction option.

8. Select the OK button to exit the Packages dialog.

Defining the Species

For a pre-defined reaction package, the appropriate list of species would be automatically loaded by GMS. However, for user-defined reactions, we must explicitly define the species.

1. Select the Define species button

2. If a name file appropriate to the user-defined reaction package is available, we can click on the Import button to initialize all species names in a single step (see Section 5.15). Since it is not available (we are using this new module for the first time), we have to define the species manually. To begin this process, click on the New button.

3. Type the name of the species as: PCE

4. Leave the mobile option checked (this is the default)

5. Click on New again

6. Type the name of the species as: TCE

7. Click on New again

8. Type the name of the species as: DCE

9. Click on New again

10. Type the name of the species as: VC
11. Press Enter

Notice that the Starting Concentration section of the dialog now lists all the four species associated with our new reaction module. By default all of the starting concentrations are zero. Since the aquifer is assumed to be initially clean, we will simply accept the default values for starting concentrations.

**Defining the Layer Parameters**

Next, we will define the layer parameters. The aquifer is a uniform horizontal aquifer with a top elevation of 10 m, a thickness of 10 m, and a porosity of 0.3.

1. Select the HTOP button.
2. Select the Constant -> Grid button.
3. Enter a value of 10 and select OK.
4. Select the OK button to exit the HTOP dialog.
5. Select the Thickness button.
6. Select the Constant -> Grid button.
7. Enter a value of 10 and select OK.
8. Select the OK button to exit the HTOP dialog.
9. Select the Porosity button.
10. Select the Constant -> Grid button.
11. Enter a value of 0.3 and select OK.
12. Select the OK button to exit the Porosity dialog.

**Setting up the Stress Periods**

Next, we will define the stress periods. Since the injection rate and the boundary conditions do not change, we will use a single stress period with a length of 730 days (three years).

1. Select the Stress Periods button.
2. Select the Initialize button.
3. Enter 1 for the No. of stress periods, 730 for the Length, 10 for the No. of time steps, leave the Transport step size at 0.0, and select OK.
4. Select OK at the prompt.

5. Select the OK button to exit the Stress Periods dialog.

Output Options
Finally, we will define the output options. One binary solution file is created by RT3D for each of the species. By default, RT3D saves a solution at each transport step for each species. Since this results in large files containing more solutions than we need for the simple post-processing we intend to do, we will specify that a solution be saved every 73 days (every time step).

1. Select the Output Control button.

2. Select the Print at specified times button.

3. Select the Times button.

4. Select the Initialize Values button.

5. Enter 73.0 for the Initial time step size.

6. Enter 73.0 for the Maximum delta time step.

7. Enter 730.0 for the Maximum simulation time.

8. Select the OK button to exit the Variable Time Steps dialog.

9. Select the OK button to exit the Output Control dialog.

This completes the input for the Basic Transport package.

Select the OK button to exit the Basic Transport Package dialog.

5.10.2 The Advection Package
The next step is to initialize the data for the Advection package.

1. Select the Advection Package command from the MT3D/RT3D menu.

2. Select the Upstream finite-difference option.

3. Select the OK button to exit the dialog.

5.10.3 The Dispersion Package
Next, we will enter the data for the Dispersion package. The aquifer has a longitudinal dispersivity of 10.0 m and a transverse (horizontal) dispersivity of
3.0 m. The vertical dispersivity is assumed equal to the longitudinal dispersivity.

1. Select the Dispersion Package command in the MT3D/RT3D menu.

2. Select the Longitudinal Dispersivity button.

3. Select the Constant -> Grid button.

4. Enter a value of 10.0 and select OK.

5. Select the OK button to exit the Longitudinal Dispersivity dialog.

6. Enter a value of 0.3 for the Ratio of the trans. dispersivity to long. dispersivity value.

7. Select the OK button to exit the Dispersion Package dialog.

5.10.4 The Source/Sink Mixing Package

Next, we will initialize the Source/Sink Mixing package and define the concentration at the spill location.

1. Select the Source/Sink Mixing Package command in the MT3D/RT3D menu.

2. In the Source/Sink Types section, select the Well option.

3. In the Initialize section, select the Well option.

4. Select the OK button.

We will define the concentrations at the wells by selecting the cells and assigning the concentration directly with the Point Source/Sink command. We will assign a concentration of 1000 mg/L for PCE and leave TCE, DCE, and VC concentrations at the default value of 0.0.

1. Select the Select Cell tool.

2. Select the well at the spill location.

3. Select the Point Source/Sink command in the MT3D/RT3D menu.

4. In the Well section, note appropriate species names are automatically set at this menu based on your earlier definition. Select the PCE species and enter a value of 1000.0 for concentration.
5. Select the OK button to exit the Point Source/Sink dialog.

5.10.5 The Chemical Reaction Package

Next, we will review the data for the Chemical Reaction package.

Select the Chemical Reaction Package command in the MT3D/RT3D menu.

Note that the reaction parameter box is blank. We will leave it blank in this case because in the DLL we coded all of the reaction constants directly within the reaction subroutine. We will demonstrate how to define them as user-defined variables later in this tutorial.

Select the OK button to accept the defaults.

5.11 Running RT3D

At this point, we are ready to save the model and run RT3D.

1. Select the Save Simulation command from the MT3D/RT3D menu.

2. At the top of the dialog, enter "rtmod1" for the prefix.

3. To the right of the prefix, select the Update button.

4. At the top of the dialog, select the File Browser button.

5. In the Save File dialog, locate and open the directory entitled gms/tutorial/rt3d/userdef/.

6. Select the Save button to exit the Save File dialog.

7. Select the OK button to save the files.

To run RT3D:

1. Select the Run RT3D command from the MT3D/RT3D menu.

2. Select OK at the prompt.

3. When the simulation is finished, close the window and return to GMS.
5.12 Viewing the Results

To view the results, select the Open command from the File menu and import the rtmod1.dss file to view the results. To verify your results, compare the concentration values with the output from the tutorial entitled: Sequential Anaerobic Degradation: PCE->TCE->DCE->VC.

5.13 Developing a Reusable Reaction Package

Defining a new reaction model via a reaction package is a powerful option supported by the RT3D code. Once tested and developed, the reaction package (or DLL) can be used in other projects that have different conceptual flow and transport models. DLLs can also be distributed via web pages to other users who might be interested in modeling similar type of reactive transport systems. This section outlines the steps involved in developing a reusable version of reaction package.

In an earlier section, we mentioned that there are three different methods available for coding the reaction subroutine. Method-#1, which is the preferred method for testing and debugging a new reaction package, was discussed in detail in previous sections. Now, let’s assume that we have sufficiently tested the reaction package and are ready to distribute the package to other users who might be interested in using it without having to recompile the code. To accomplish this, we have to re-code the reaction package based on either method-#2 or method-#3. We will utilize method-#3 (which is the most advanced method) here for demonstration purposes. As described earlier, method-#3 provides an option to let some or all of the reaction parameters be defined as spatially variable parameters. This method also allows the user to set the values of reaction parameters via the *.RCT input file (i.e., in the Chemical Reactions Package dialog in GMS).

5.13.1 Editing the Source Code

In this test problem, we have a total of seven reaction parameters. For illustration purposes, we will assume that five of them are constant parameters: $K_{pce}$, $K_{tce}$, $Y_{tce,pce}$, $Y_{dce,tce}$, and $Y_{vc,dce}$ (note NCRXNDATA = 5), and two of them are spatially variable parameters: $K_{dce}$ and $K_{vc}$ (note NVRXNDATA = 2). The following FORTRAN listing for the reaction module (using method-#3) incorporates these changes:

```
SUBROUTINE rxns(ncomp,nvrxndata,j,i,k,y,dydt,
  poros,rhob,reta,rc,nlay,nrow,ncol,vrc)

  c ***** Block 1: Comments block ********
  c23456789012345678901234567890123456789012345678901234567890123456789012
  c ncomp - Total number of components
  c nvrxndata - Total number of variable reaction parameters to be input via RCT file
  c J, I, K - node location (used if reaction parameters are spatially variable)
  c y - Concentration value of all component at the node [array variable y(ncomp)]
  c dydt - Computed RHS of your differential equation (array variable dydt(ncomp)]
  c poros - porosity of the node
```
User-Defined Reactions

5-17

---

c reta - Retardation factor [array variable dpreta(mcomp)]
c rhob - Bulk density of the node
c rc - Stores spatially constant reaction parameters (up to 100 values)
c nlay, nrow, ncol - Grid size (used only for dimensioning purposes)
c vrc - Array variable that stores spatially variable reaction parameters

---

c *** Block 2: Please do not modify this standard interface block ***
!MS$ATTRIBUTES DLLEXPORT :: rxns
IMPLICIT NONE
INTEGER ncol,nrow,nlay
INTEGER ncomp,nvrxndata,j,i,k
INTEGER First_time
DATA First_time/1/
DOUBLE PRECISION y,dydt,poros,rhob,reta
DOUBLE PRECISION rc,vrc
DIMENSION y(ncomp),dydt(ncomp),rc(50)
DIMENSION vrc(ncol,nrow,nlay,nvrxndata),reta(50)

---

c *** Block 3: Declare your problem-specific new variables here ***

---

C *** Block 4: INITIALIZE YOUR CONSTANTS HERE, IF DESIRED ***
IF (First_time .EQ. 1) THEN
kpce = rc(1) !PCE first-order degradation rate (constant)
ktce = rc(2) !TCE first-order degradation rate (constant)
kdc is a spatially variable parameter, it is defined in block-5
kvc is a spatially variable parameter, it is defined in block-5
ytcepce = rc(3)
ydctcetce = rc(4)
yvcde = rc(5)
First_time = 0 !reset First_time to skip this block later
END IF

---

C *** Block 5: Definition of other variable names ***
pce = y(1)
tce = y(2)
dce = y(3)
vvc = y(4)
kdc = vrc(j,i,k,1) !Spatially variable DCE decay rate

---

C *** Block 6: Definition of Differential Equations ***
dydt(1) = -kpce*pce/reta(1)
dydt(2) = (-ktce*tce + kpce*pce*ytcepce)/reta(2)
dydt(3) = (-kdc*dce + ktce*tce*ydctcetce)/reta(3)
dydt(4) = (-kvc*vvc + kdc*dce*yvcde)/reta(4)

---

RETURN
END

Note that this subroutine is identical to the previous version except that in blocks 4 and 5, the rc() and vrc() arrays are used to initialize reaction parameters. The values of the parameters will be defined in the RT3D input file *.RCT. In the section below, we will demonstrate how the reaction parameter values can be defined efficiently using the GMS interface.

5.13.2 Compiling the Source Code

Now follow the steps detailed in Section 5.4 to compile and create a new rxns.dll file. The FORTRAN source code is provided in the following file:

gms\tutorial\rt3d\userdef\rxns_2.f
Once the source is compiled, rename the DLL as rxns.dll and copy it to the GMS subdirectory where RT3D.EXE is saved. If you wish to preserve the previous version of the rxns.dll file, you will need to rename the old version before copying the new version to the GMS directory.

Once again, if you do not have access to a FORTRAN compiler but wish to continue with the tutorial, you can find a pre-compiled copy of rxns_2.dll in the tutorial/rt3d/userdef/ directory.

### 5.14 Modifying the Transport Model

We are now ready to use the new module for reactive transport simulations. If you have exited GMS, or if you have made any changes to the RT3D simulation defined above, you will need to re-import both the MODFLOW and RT3D simulation.

#### 5.14.1 The Chemical Reaction Package

Next, we will define and initialize the chemical reaction parameters.

Select the Chemical Reaction Package command in the MT3D/RT3D menu.

Note that the reaction parameter box is blank. In this section, we will define and initialize the reaction parameters.

1. Click on Define Parameters button.
2. Once again, if a name file appropriate to the user-defined reaction package, is available, we can click on the Import button and initialize all reaction parameter names in a single step (see Section 5.15). Since it is not available in this case, we will define them manually. To begin this process, click on New button.
3. Enter the name of reaction parameter as: Kpce.
4. Do not select the Spatially variable option (it is off by default).
5. Click on New.
6. Enter the name of reaction parameter as: Ktce
7. Click on New.
8. Enter the name of reaction parameter as: Kdce
9. Select the *Spatially variable* option.

10. Click on *New*.

11. Enter the name of reaction parameter as: Kvc

12. Check the *Spatially variable* option.

13. Click on *New*.

14. Enter the name of reaction parameter as: Ytce_pce

15. Click on *New*.

16. Enter the name of reaction parameter as: Ydce_tce

17. Click on *New*.

18. Enter the name of reaction parameter as: Yvc_dce

19. Select the *OK* button.

Now notice in the *Define Parameters* section all the reaction parameters are listed. Next, we will assign values for all these parameters.

1. In the *Reaction Parameters* section, click on K_{pce} and set the constant value to 0.005.

2. Click on K_{tce} and set the constant value to 0.003

3. Click on Y_{tce,pce} and set the constant value to 0.792

4. Click on Y_{dce,tce} and set the constant value to 0.738

5. Click on Y_{vc,dce} and set the constant value to 0.644

6. Now, click on K_{vc} (variable).

7. Select the *Variable* button.

8. Click on *Constant to Grid* option and set the value to 0.002

9. Click on K_{vc} (variable)

10. Select the *Variable* button.

11. Click on *Constant to Grid* option and set the value to 0.001

12. Select the *OK* button.
We have defined five spatially constant reaction parameters and two spatially variable reaction parameters. Therefore, in the *.RCT package file, NCRXNDATA will be set to 5 and NVRXNDATA will be set to 2. During execution, the RT3D code stores and transfers all the constant reaction parameters through a one-dimensional reaction constant array rc(). The parameter values are transferred in the order in which they are originally entered; i.e. K_{pce} is stored in rc(1), K_{tce} is stored in rc(2) and so on. Similarly, all the variable reaction parameters are stored and transferred through a four-dimensional variable reaction constant array vrc().

Note that although two of the reaction parameters can vary spatially, for the sake of keeping this tutorial simple, we have assigned a single value to all cells in both cases. The reaction parameters can be edited on a cell by cell basis using the array editor dialog in the Chemical Reaction package or by selecting a set of cells and selecting the Cell Attributes command in the MT3D/RT3D menu.

### 5.14.2 Running RT3D

At this point, we are ready to save the model to run RT3D.

1. Select the Save Simulation command from the MT3D/RT3D menu.
2. At the top of the dialog, enter "rtmod2" for the prefix.
3. To the right of the prefix, select the Update button.
4. At the top of the dialog, select the File Browser button.
5. In the Save File dialog, locate and open the directory entitled gms/tutorial/rt3d/userdef.
6. Select the Save button to exit the Save File dialog.
7. Select the OK button to save the files.

To run RT3D:

1. Select the Run RT3D command from the MT3D/RT3D menu.
2. Select OK at the prompt.
3. When the simulation is finished, close the window and return to GMS.
5.14.3 Viewing the Results

Select the Data Browser command from the Data menu and import the appropriate concentration files to view the results. The results should be similar to those computed earlier.

5.15 Creating a Name File for GMS import

When a new reaction package is created, the package developer should create a name file. The information regarding species names, species types, species order, reaction parameter names, reaction parameter types, and reaction parameter sequence are stored in a name file. All of the information needed for a name file is included in the RT3D super file created by GMS. Thus, the simplest way to create the name file is to set up the first simulation using the steps defined above and then open the RT3D super file for the simulation (*.rts) in a text editor. Delete all the cards except the first card, and the cards beginning with SPC and RXNPARAM. The edited file should look like this:

```
RT3DSUP
SPC "PCE" 1 1
SPC "TCE" 2 1
SPC "DCE" 3 1
SPC "VC" 4 1
RXNPARAM "kdce" 3 1
RXNPARAM "kvc" 4 1
RXNPARAM "kpce" 1 0
RXNPARAM "ktce" 2 0
RXNPARAM "Ytce_pce" 5 0
RXNPARAM "Ydc_tce" 6 0
RXNPARAM "Yvc_dce" 7 0
```

Save this information in a new file, say “specie.nam”. This file can be later used for directly importing species and reaction parameter information. Whenever a user-defined reaction package (as a DLL or source code) is distributed to another GMS user, a specie name file, appropriate to the reaction package, should be included with it.

5.15.1 Importing Species Names

The specie name file can be used to set-up a new RT3D transport problem using a (previously developed) user-defined reaction package. To import the specie names into GMS, select Basic Transport Package, click on the Define Species option, click on the Import button, and read the “specie.nam” file. These steps will import appropriate species names in the correct order.

5.15.2 Importing Reaction Parameter Names

To import reaction parameter names, select Chemical Reaction Package, click on Define Parameters option, click on Import button, and read the
“specie.nam” file again. This will import appropriate reaction parameter names in the correct order.

5.16 Special Instructions for UNIX Users

Since development of a DLL requires Microsoft or Digital’s visual FORTRAN compiler specific commands, this option is incompatible with Unix platforms. Therefore, Unix users should always comment the first line in the block-2 of rxns.f file that begin with a command “!MS$ATTRIBUTES”. Also whenever any changes are made to the RXNS.F code, the RT3D executable should to be recreated, using a FORTRAN-90 compiler, by linking RXNS.OBJ with the RT3D.LIB (to use RT3D) or with BATCHRXN.LIB (to use BATCHRXN).

5.17 Conclusion

This concludes the User-Defined Reactions tutorial. If you wish to exit GMS at this time:

1. Select the Exit command from the File menu.

2. Select the OK button at the prompt.
This tutorial illustrates the steps involved in using GMS and RT3D to model sorption reactions under mass-transfer limited conditions. The flow model used in this simulation is different from the one used in other example problems. Hence, the steps involved in creating input data for both the flow and the reactive transport models will be described in this tutorial exercise.

6.1 Description of the Reaction Model

The fate and transport of an organic pollutant in subsurface environments is often highly dependent on its sorption characteristics. Under most natural groundwater flow conditions, the partitioning of contaminants between the solid and aqueous phases can be assumed to be at a local equilibrium. Thus, the more widely used retardation approach for modeling sorption may provide an adequate description for the overall transport. However, when external pumping and injection stresses are imposed on an aquifer (e.g. using a pump-treat-system), the equilibrium assumption may fail. This would lead to some well-known conditions such as the plume tailing effect (i.e. low contaminant levels always observed at the extraction well) and/or the rebounding effect (i.e. aquifer seems to be clean but the aqueous concentrations start to increase immediately after stopping the treatment system). These conditions cannot be simulated using the standard linear retardation approach since they require a mass-transfer description for the sorption reactions.

In the mass-transfer limited sorption model, the exchange of contaminants between the soil and groundwater is assumed to be rate limited. The rate of exchange is dictated by the value of the mass-transfer coefficient. When the
mass-transfer rate is high (relative to the overall transport), the rate-limited model relaxes to the retardation model. On the contrary, very low mass-transfer coefficient would mimic fully sequestered conditions where the contaminants in the soil phase are assumed to be irreversibly adsorbed and trapped into the soil pores. Under this extreme condition, it might be possible to simply clean the groundwater plume and leave the sequestered soil contaminant in the aquifer because the sorbed contaminants may not pose any potential risk to the environment. In either of the extreme conditions, pump-and-treat is the best option to remediate the groundwater plume. Unfortunately, in most instances, the mass-transfer coefficient is expected to lie in an intermediate range, causing the well-known limitations to the pump-and-treat system.

When sorption is assumed to be rate-limited, it is necessary to track contaminant concentrations in both mobile (groundwater) and immobile (soil) phases. Following Haggerty and Gorelick’s (Water Resource research, 30(2), 435-446, 1994) approach, the fate and transport of a sorbing solute at aqueous and soil phases can be predicted using the following transport equations:

\[
\frac{\partial C}{\partial t} + \frac{\rho}{\phi} \frac{\partial \tilde{C}}{\partial t} = \frac{\lambda - \xi}{\phi} \left(\frac{\partial}{\partial x_i} \left( D_{ij} \frac{\partial C}{\partial x_j} \right) - \frac{\partial}{\partial x_i} (v_i C) \right) + \frac{q_s}{\phi} C_s \quad \text{.................................. (6.1)}
\]

\[
\frac{\rho}{\phi} \frac{\partial \tilde{C}}{\partial t} = \xi \left( C - \frac{\tilde{C}}{\lambda} \right) \quad \text{........................................... (6.2)}
\]

where \( C \) is the concentration of the contaminant in the mobile-phase \([\text{ML}^{-3}]\), \( \tilde{C} \) is the concentration of the contaminant in the immobile phase (mass of the contaminants per unit mass of porous media, \([\text{MM}^{-1}]\)), \( \rho \) is the bulk density of the soil matrix, \( \phi \) is the soil porosity, \( \xi \) is the first-order, mass-transfer rate parameter \([\text{T}^{-1}]\), and \( \lambda \) is the linear partitioning coefficient (which is equal to the linear, first-order sorption constant \( K_d \) \([\text{L}^{-1}\text{M}^{-1}]\)). It can be mathematically shown that the above model formulation relaxes to the retardation model when the value of \( \xi \) becomes high (see Clement et al. 1998 paper in the spring issue of Groundwater Monitoring and Remediation journal).

The mass-transfer model discussed above has been implemented as an RT3D reaction package (one mobile species and one immobile species). After employing reaction-operator splitting, the reaction package for the problem reduces to:

\[
\frac{dC}{dt} = -\xi \left( C - \frac{\tilde{C}}{\lambda} \right) \quad \text{.................................................. (6.3)}
\]
\[
\frac{d\tilde{C}}{dt} = \frac{\phi \xi}{\rho} \left( C - \frac{\tilde{C}}{\lambda} \right)
\] ...........................................................(6.4)

These two differential equations are coded into the model #4 designated as the rate-limited sorption reaction module.

6.2 Description of Problem

The example problem we will be solving in this tutorial is shown in Figure 6.1. The site is a 1000 ft x 500 ft section of an unconfined aquifer with flow gradient from left to right. A spill at the center of the site has created a contaminant plume as shown in the figure. A pump-and-treat system, using three injection and extraction well at the constant rate of 4000 ft³/day, will be used to clean the contaminant plume. Aqueous concentration of contaminant level throughout the plume is assumed to be at 300 mg/L. The linear partitioning coefficient (K₅ₖ or \(\lambda\)) for the contaminant is assumed to be 1.0x10⁻⁷ (L/mg), soil dry bulk density, \(\rho\), is assumed to be 1.5x10⁶ (mg/L), and porosity is assumed to be 0.3. Note these parameters yield an effective retardation coefficient value of 1.5 (\(R = 1 + \rho \lambda / \phi\)). Assuming equilibrium conditions exist before starting the pump-treat-treatment system, the initial soil-phase contaminant concentration levels, \(\tilde{C} = \lambda C\), can be estimated to be at 3x10⁻⁵ (mg of contaminant/ mg of soil). The objective of the treatment system is to clean both dissolved and soil-phase contamination. The model will simulate the effectiveness of the system under different mass transfer conditions. A 3000 day simulation will be performed. The mass-transfer coefficient values will be varied to simulate retardation conditions (using \(\xi = 0.1\) day⁻¹), intermediate conditions (using \(\xi = 0.002\) day⁻¹) and sequestered conditions (using 0.0001 day⁻¹). Time series plots and contour plots will be used to visualize the treatment scenarios under different field conditions.
6.3 Launching GMS

Before launching GMS, you should have installed GMS. If you have not yet installed GMS, please do so before continuing.

To launch the PC version of GMS:

Select the GMS shortcut from the Programs section in the Start menu (Windows 95, Windows NT 4.0), or double-click on the GMS icon in the GMS program group (Windows 3.1).

To launch the Unix version of GMS:

4. Bring up an xterm window.

5. Change to the directory containing the GMS executable.

6. Type gms at the command line.

6.4 Required Modules/Interfaces

This tutorial utilizes the following components of the GMS interface:
6.5 Building the Flow Model

The first step in setting up the problem is to build the MODFLOW flow model. The model will be a steady state one layer unconfined model with 20 ft X 20 ft cells. The flow solution will then be used to drive the transport model.

6.5.1 Reading in the Map File

Before creating the flow model, we will first read in a map file that contains some drawing objects for background display that will aid in building the model.

1. Select the Open command in the File menu.

2. In the Open dialog, locate and open the file entitled gms/tutorial/rt3d/rlimsorp/site.map

The blue rectangle is the model boundary and the red rectangle is the spill location.

6.5.2 Creating the Grid

To create the grid:

1. Switch to the 3D Grid module

2. Select the Create Grid command from the Grids menu.
3. In the X-Dimension section, set the Length to 1000 and the Number of cells to 50.

4. In the Y-Dimension section, set the Length to 500 and the Number of cells to 25.

5. In the Z-Dimension section, set the Number of cells to 1.

6. Select the OK button.

### 6.5.3 The Basic Package

Next, we will define the data in the Basic package.

1. Select the Basic Package command from the MODFLOW menu.

2. Select the New button to initialize the MODFLOW data.

3. For the first heading, enter "Flow Model".

4. For the second heading, enter your name.

5. In the Time Units section, select Days.

#### Packages

Next, we will select the packages.

1. Select the Packages button.

2. Turn on the Well package.

3. In the Solver section, select the PCG2 option.

4. Select the OK button.

#### IBOUND

The IBOUND array is used to designate the constant head boundaries. However, we will mark the boundaries later in the tutorial by directly selecting the cells.

#### Starting Head

We will assign a starting head of 21 ft everywhere in the grid.

1. Select the Starting Head button.

2. Select the Constant -> Layer button.
3. Select OK at the prompt.
4. Enter a value of 21.
5. Select the OK button twice to return to the Basic Package dialog.

**Specified Head Boundaries**

Next, we will define the specified head boundaries.

1. Select the OK button to exit the Basic Package dialog.

2. Choose the Select Column tool.

3. Click once in any of the cells in the leftmost column of the grid.

4. Select the Cell Attributes command in the MODFLOW menu.

5. Change the IBOUND value to –1.

6. Select the OK button.

7. Click once in any of the cells in the rightmost column of the grid.

8. Select the Cell Attributes command in the MODFLOW menu.

9. Change the IBOUND value to –1.

10. Change the Starting head value to 18.

11. Select the OK button.

12. Click anywhere outside the grid to unselect the cells.

This concludes the input for the Basic package.

### 6.5.4 The BCF Package

Next, we will define the input for the BCF package.

1. Select the BCF Package command from the MODFLOW menu.

2. In the upper left corner of the dialog, select the Steady State option.

**Hydraulic Conductivity**

The hydraulic conductivity is constant throughout the grid.
1. Select the *Hydraulic Conductivity* button.

2. Select the *Constant -> Layer* button.

3. Enter a value of 10.

4. Select the *OK* button twice to return to the *BCF Package* dialog.

**Bottom Elevation**

The bottom elevation is a constant value of zero throughout the grid. Since zero is the default value, no changes need to be made.

To exit the dialog:

Select the *OK* button.

### 6.5.5 Creating the Wells

Next, we will create the wells. To create the injection wells:

1. Choose the *Select Cell* tool.

2. While monitoring the ijk indices in the *Edit Window*, locate and select the cell at (I=7, J=16).

3. While holding down the *Shift* key, locate and select the cells at (I=13, J=16) and (I=19, J=16).

4. Select the *Point Sources/Sinks* command from the *MODFLOW* menu.

5. In the *Well* section, select the *Add* button.

6. Enter a value of 900 for *Q*.

7. Select the *OK* button.

8. Click anywhere outside the grid to unselect the cells.

To create the extraction wells:

1. While holding down the *Shift* key, locate and select the cells at (I=7, J=33), (I=13, J=33) and (I=19, J=33).

2. Select the *Point Sources/Sinks* command from the *MODFLOW* menu.

3. In the *Well* section, select the *Add* button.
4. Enter a value of -900 for $Q$.

5. Select the OK button.

6. Click anywhere outside the grid to unselect the cells.

### 6.5.6 Saving and Running the Flow Model

At this point, we are ready to save the model and run MODFLOW.

1. Select the Save Simulation command from the MODFLOW menu.

2. At the top of the dialog, enter "flowmod" for the prefix.

3. To the right of the prefix, select the Update button.

4. At the top of the dialog, select the File Browser button.

5. In the Save File dialog, locate and open the directory entitled `gms/tutorial/rt3d/rlimsorp`.

6. Select the Save button to exit the Save File dialog.

7. Select the Save button to save the files.

To run MODFLOW:

1. Select the Run MODFLOW command from the MODFLOW menu.

2. Select OK at the prompt.

3. When the simulation is finished, close the MODFLOW window and return to GMS.

### 6.5.7 Viewing the Solution

Finally, before proceeding to build the transport model, we will import and view the flow solution.

1. Select the Data Browser command from the Data menu.

2. Select the Import button on the left side of the dialog.

3. Select the MODFLOW scalar file option and select OK.

4. Select and open the file titled "flowmod.hed".

5. Select the Done button to exit the Data Browser.
To turn on the display of contours:

1. Select the Display Options command in the Display menu.
2. Turn on the Layer Contours option.
3. Select the OK button.

You should see a series of contours indicating a flow from left to right with mounds around the injection wells and cones of depression around the extraction wells.

### 6.6 Building the Transport Model

We are now ready to build the RT3D transport model. We will first build a model that simulates retardation conditions. We will then compare that solution to a solution from MT3D. Finally, will compare the retardation solution to a solution representing intermediate and sequestered conditions.

#### 6.6.1 The Basic Transport Package

First, we will define the data for the Basic Transport package.

1. Select the Basic Transport Package command from the MT3D/RT3D menu.
2. Select the New button to initialize the data.
3. In the Units section, enter d for the time units, ft for the length units, and lb for the mass units.
4. In the Model section, select RT3D.
5. For the first heading, enter "Transport Model – Retardation Condition".
6. Enter your name for the second heading.
7. Change the time units to "Days" and the length units to "Ft".

Packages

Next, we will select which packages we will use:

1. Select the Packages button.
2. Turn on all four packages.
3. In the RT3D Reactions section, select the reaction titled Rate-Limited Sorption Reactions.

4. Select the OK button.

**Stress Periods**

Next, we will define a single stress period with a length of 3000 days.

1. Select the Stress Periods button.

2. Change the Length value to 3000.0.

3. Select the OK button.

**Output Control**

By default, RT3D outputs a solution at every transport step. We will change this so that a solution is output every 200 days.

1. Select the Output Control button.

2. Select the Print at specified times button.

3. Select the Times button.

4. Starting at 200, enter the time values in increments of 200 days up to the value of 3000 (i.e., 200, 400 ... 2800, 3000). Hit the Enter key after entering each value to move to the next field.

5. Select the OK button twice to return to the Basic Transport Package dialog.

**Layer Data**

The next step is to enter the layer data (top elevation, thickness, and porosity). For the geometry, we will assume a uniform thickness of 25 ft.

1. Select the HTOP button.

2. Select the Constant -> Layer button.

3. Enter a value of 25.

4. Select the OK button twice to return to the Basic Transport Package dialog.

5. Using steps 1-4, enter a value of 25 for the thickness and a value of 0.3 for the porosity.
Starting Concentrations

A starting concentration must be defined for both the aqueous phase concentration and the solid phase concentration. The default starting concentrations are zero. We need to change the starting concentrations at the plume location. While this can be accomplished with the Starting Concentration dialog, it is more convenient to select the cells and directly assign the values.

1. Select the OK button to exit the Basic Transport Package dialog.

2. Drag a box that just encloses the red rectangle defining the spill location.

Before assigning the values, we will unselect the cells in the four corners of the grid. This will give the plume a slightly more rounded shape.

1. While holding down the Shift key, select each of the cells in the four corners of the spill location.

2. Select the Cell Attributes command in the MT3D/RT3D menu.

3. Make sure that Aqueous conc. is highlighted and enter a value of 300 for the starting concentration.

4. Highlight the Solid conc. item and enter a value of 3.0e-5 for the starting concentration.

5. Select the OK button.

6. Click anywhere outside the grid to unselect the cells.

This completes the input for the Basic Transport package.

6.6.2 The Advection Package

Next, we will define the input data for the Advection package.

1. Select the Advection Package command from the MT3D/RT3D menu.

2. Select the Modified method of characteristics option.

3. Select the Particles button.

4. At the top of the dialog, change the Max # of cells… value to 2.

5. Select the OK button twice to exit both dialogs.
6.6.3 **The Dispersion Package**

Next, we will enter the data for the Dispersion package.

1. Select the *Dispersion Package* command from the *MT3D/RT3D* menu.
2. Select the *Longitudinal Dispersivity* button.
3. Select the *Constant -> Layer* button.
4. Enter a value of 10.
5. Select the *OK* button twice to return to the *Dispersion Package* dialog.
6. Enter a value of 0.1 for the *Ratio of trans. dispersivity to long. dispersivity* value.
7. Select the *OK* button.

6.6.4 **The Source/Sink Mixing Package**

For the Source/Sink Mixing Package, we will assign a zero concentration to the incoming fluid from the injection wells.

1. While holding the *Shift* key, select each of the three injection wells (the wells on the left).
2. Select the *Point Sources/Sinks* command.
3. Turn on the *Well* option.
4. Leave the concentration at zero and select the *OK* button to exit.
5. Click anywhere outside the grid to unselect the cells.

6.6.5 **The Reaction Package**

The last step in setting up the transport model is to enter the data for the Reaction package.

1. Select the *Chemical Reaction Package* command from the *MT3D/RT3D* menu.
2. Enter a value of 1.5e6 for the *Dry Bulk Density*.
3. In the *Reaction Parameters* section, make sure that the *mass transfer coeff.* item is highlighted and enter a constant value of 0.1.
4. Highlight the *partitioning coeff.* item and enter a value of 1.0e-7.

5. Select the *OK* button to exit.

### 6.6.6 Saving and Running the Simulation

At this point, we are ready to save the model and run *RT3D*.

8. Select the *Save Simulation* command from the *MT3D/RT3D* menu.

9. At the top of the dialog, enter "retard" for the prefix.

10. To the right of the prefix, select the *Update* button.

11. At the top of the dialog, select the *File Browser* button.

12. In the *Save File* dialog, locate and open the directory entitled `gms/tutorial/rt3d/rlimsorp`.

13. Select the *Save* button to exit the *Save File* dialog.

14. Select the *Save* button to save the files.

To run *RT3D*:

4. Select the *Run RT3D* command from the *MT3D/RT3D* menu.

5. Select *OK* at the prompt.

6. When the simulation is finished, close the *RT3D* window and return to *GMS*.

### 6.6.7 Viewing the Solution

To view the RT3D solution:

1. Select the *Open* command from the *File* menu.

2. Select and open the file titled "retard.dss".

3. Select the *Data Browser* command in the *Data* menu.

First, we will view the solid phase concentration solution at 600 days.

1. Select the time step at t=600 days.

2. Select the *Done* button to exit the *Data Browser*. 
To better illustrate the variations, we will turn on the color ramp.

1. Select the *Contour Opts* command from the *Data* menu.

2. In the lower right corner of the dialog, select the *Use color ramp* option.

3. Select the *OK* button.

Next, we will view the aqueous phase concentration solution at 600 days.

1. Select the *Data Browser* command in the *Data* menu.

2. Select the data set titled *Aqueous*.

3. Select the time step at t=600 days.

4. Select the *Done* button to exit the *Data Browser*.

Notice that although the magnitude of the concentration values are different, the spatial distribution of the plume is identical for the solid and aqueous phase.

### 6.7 Comparison to Other Solutions

Next, we will compare our initial solution to other solutions with different mass transfer coefficients. To save time, these solutions have already been computed. We simply need to read them into GMS.

Before reading in other solutions, we will rename the two data sets currently in memory to help us keep track of the solutions.

1. Select the *Data Browser* command from the *Data* menu.

2. Select the *Aqueous* data set.

3. Select the *Info* button.

4. Change the name of the data set to "Aqueous (Retard)".

5. Repeat steps 2-4 and change the name of the other data set from "Solid" to "Solid (Retard)".
6.7.1 Importing the Solutions

Next we will read in the previously computed solutions. Although the solutions were originally created in separate files, the solutions have been combined into a single data set file for convenience.

1. Select the Import button from the left side of the Data Browser.
2. Select OK at the prompt.
3. Select and open the file entitled othersol.dat.

The following data sets should appear in the Data Browser:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Aqueous (mt3d)</td>
<td>Solution from an MT3D simulation</td>
</tr>
<tr>
<td>Solid (interm)</td>
<td>Solution from an RT3D simulation with the mass transfer coeff. = 0.002.</td>
</tr>
<tr>
<td></td>
<td>This represents an intermediate condition between the retardation condition and the sequestered condition.</td>
</tr>
<tr>
<td>Solid (sequest)</td>
<td>Solution from an RT3D simulation with the mass transfer coeff. = 0.0001.</td>
</tr>
<tr>
<td></td>
<td>This represents the sequestered condition.</td>
</tr>
</tbody>
</table>

6.7.2 MT3D Solution

First, we will examine the MT3D simulation. The solution we have computed has a large mass transfer rate and simulates retardation conditions. Therefore, it should be very similar to a solution computed using MT3D. To confirm this:

1. Select the data set titled "Aqueous (mt3d).
2. Select the time step at t = 600 days.
3. Select the Done button to exit the Data Browser.

Note that the spatial distribution of the plume appears to be identical. A nice way to compare the results is to set up a time series plot. First, we will switch to the Map module and create an observation point.

1. Switch to the Map module.
2. Select the Coverages command in the Feature Objects menu.
3. Change the coverage type to Observation.
4. Select the Options button next to the Observation option.
5. Turn on the Interpolate in layer only option.
6. Select OK to exit both dialogs.

7. Select the Create Point tool

8. While monitoring the cursor coordinates in the Edit Window, move the cursor approximately to (x=610, y=250) and click once to create a point.

Next, we will set up the time series plot.

1. Select the Obs. Plot Options command from the Display menu.

2. Select the New button.

3. Change the type to Time Series.

4. Turn on the Curve legend option.

5. Select the Options button.

6. Select the Use selected data set option.

7. Highlight the data sets and set the Display flag so that the Aqueous (retard) data set and the Aqueous (mt3d) data set are "on" but the other data sets are all "off".

8. Select the OK button twice to exit both dialogs.

9. Select the Open/Close Plot Window command from the Display menu.

Notice that the plots are almost identical.

Before continuing, we will close the Plot Window.

Click in the corner of the Plot Window to close it.

6.7.3 Comparing the Solid Phase Concentrations

Next, we will look at the solid phase concentrations and analyze the effect of the mass transfer coefficients.

1. Switch to the 3D Grid module

2. Select the Data Browser command from the Data menu.

3. Select the Solid (retard) data set.
4. Select the time step at $t = 600$ days.

5. Select the *Done* button.

Notice that after 600 days, the bulk of the plume has moved over to the vicinity of the extraction wells.

Next, we will look at the intermediate solution. This solution was computed using a mass transfer coefficient of 0.002. This is part way between the retarded condition and the sequestered condition.

1. Select the *Data Browser* command from the *Data* menu.

2. Select the *Solid (interm)* data set.

3. Select the time step at $t = 600$ days.

4. Select the *Done* button.

Notice that some of the plume has moved toward the extraction wells but much of the plume is still in the original location.

Next, we will examine the sequestered solution. This solution was computed using a mass transfer coefficient of 0.0001.

1. Select the *Data Browser* command from the *Data* menu.

2. Select the *Solid (sequest)* data set.

3. Select the time step at $t = 600$ days.

4. Select the *Done* button.

### 6.7.4 Time Series Plot

Finally, will generate a time series plot that compares the solid phase solutions.

1. Switch to the *Map* module.

2. Select the *Obs. Plot Options* command from the *Display* menu.

3. Select the *New* button.

4. Change the type to *Time Series*.

5. Turn on the *Curve legend* option.
6. Select the *Options* button.

7. Select the *Use selected data set* option.

8. Highlight the data sets and set the *Display* flag so that the solid data sets are all "on" and the aqueous data sets are all "off".

9. Select the *OK* button twice to exit both dialogs.

10. Select the *Open/Close Plot Window* command from the *Display* menu.

11. Click on the observation point to select it.

You may wish to examine the solution vs. time at other points in the grid. This can be accomplished simply by dragging the observation point to a new location. Try dragging the point so that it is inside the box indicating the original plume location. You may need to reposition the Plot Window before moving the point.

### 6.8 Conclusion

This concludes the tutorial: *Rate-Limited Sorption Reaction*. If you wish to exit *GMS* at this time:

1. Select the *Exit* command from the *File* menu.

2. Select the *OK* button at the prompt.
This tutorial illustrates the steps involved in using GMS and RT3D to model the reaction between an electron donor and an electron acceptor, mediated by an actively growing microbial population that exist in both soil and aqueous phases. Since the flow model used in this simulation is similar to the flow model used in Chapter 2 Instantaneous Aerobic Degradation, the steps involved in building the flow model will not be described in this tutorial. A pre-defined version of the flow model will be used.

### 7.1 Description of the Reaction Model

Methods for enhancing in situ bioremediation of subsurface soil and groundwater involve injection or infiltration of a carbon source (or electron donor), nutrients, and other electron acceptors to stimulate the growth of native microbes. In addition, bioengineered suspension cultures of contaminant degrading organisms may be also added to increase the amount of attached and suspended biomass in the subsurface. These two types of active remediation techniques can be used to bioremediate contaminated source zones or to establish a biobarrier to prevent plume migration and/or to enhance plume attenuation. The successful use of subsurface microbes for bioremediation requires an understanding of coupled flow, transport, and reaction processes that control bacterial growth and migration patterns. The Dual-Monod model, available in the RT3D code, can be used to develop such understanding by simulating the coupled reactive transport and microbial growth. The model is developed in a general format; therefore, the interaction between any electron donor and acceptor mediated by any type of microbial population can be simulated by varying appropriate kinetic constants.
Advanced users can modify this basic formulation and couple it with other packages, such as the sorption package, to simulate more realistic bioremediation scenarios (any such modified reaction models can be easily implemented via the user-defined reaction option).

Assuming the linear-equilibrium model for modeling sorption, and the Dual-Monod model for modeling bacterial growth, the fate and transport equation for an electron donor (hydrocarbon, for example) in a multi-dimensional saturated porous media can be written as:

\[
R_d \frac{\partial [D]}{\partial t} = \frac{\partial}{\partial x_i} \left( D_{ij} \frac{\partial [D]}{\partial x_j} \right) - \frac{\partial}{\partial x_i} \left( v_i [D] \right) + \frac{q_{ds} [D_s]}{\phi} - \mu_m \left( [X] + \frac{\rho \tilde{X}}{\phi} \right) \left( \frac{[D]}{K_D + [D]} \right) \left( \frac{[A]}{K_A + [A]} \right) \]

where \([D]\) is the electron donor concentration in the aqueous phase \([\text{ML}^{-3}]\), \([D_s]\) is the donor concentration in the sources/sinks \([\text{ML}^{-3}]\), \(D_{ij}\) is the dispersion coefficient; \([X]\) is the aqueous phase bacterial cell concentration \([\text{ML}^{-3}]\), \(\tilde{X}\) is the solid-phase cell concentration (mass of bacterial cells per unit mass of porous media \([\text{MM}^{-1}]\)), \([A]\) is the electron acceptor concentration in the aqueous phase \([\text{ML}^{-3}]\), \(R_H\) is the retardation coefficient of the hydrocarbon, \(K_D\) is the half saturation coefficient for the electron donor \([\text{ML}^{-3}]\), \(K_A\) is the half saturation coefficient for the electron acceptor \([\text{ML}^{-3}]\), and \(\mu_m\) is the contaminant utilization rate \([\text{T}^{-1}]\). The model assumes that the degradation reactions occur only in the aqueous phase, which is usually a conservative assumption.

The fate and transport of the electron donor (oxygen, for example) can be modeled using the equation:

\[
R_A \frac{\partial [A]}{\partial t} = \frac{\partial}{\partial x_i} \left( D_{ij} \frac{\partial [A]}{\partial x_j} \right) - \frac{\partial}{\partial x_i} \left( v_i [A] \right) + \frac{q_{As} [A_s]}{\phi} - Y_{A/D} \mu_m \left( [X] + \frac{\rho \tilde{X}}{\phi} \right) \left( \frac{[D]}{K_D + [D]} \right) \left( \frac{[A]}{K_A + [A]} \right) \]

where \(Y_{A/D}\) is the stoichiometric yield coefficient, and \(R_A\) is the retardation coefficient of the electron acceptor.

The fate and transport of bacteria in the aqueous phase can be described using the equation:
\[ \frac{\partial [X]}{\partial t} = \frac{\partial}{\partial x_i} \left(D_i \frac{\partial [X]}{\partial x_i} \right) - \frac{q_i}{\phi} [X_i] + [A] + K_{att}[X] + K_{det}[X] + \frac{K_{det}[X]}{\phi} + \] 
\[ Y_{X/D} \mu_m[X] \left( \frac{[D]}{K_D + [D]} \right) \left( \frac{[A]}{K_A + [A]} \right) - K_e[X] \]

\[ \text{............... (7.3)} \]

where \( K_{att} \) is the bacterial attachment coefficient \([T^{-1}]\), \( K_{det} \) is the bacterial detachment coefficient \([T^{-1}]\), and \( K_e \) is the endogenous cell death or decay coefficient \([T^{-1}]\).

The growth of attached-phase bacteria can be described using an ordinary differential equation of the form:

\[ \frac{d\tilde{X}}{dt} = \frac{K_{att}[X]}{\rho} - K_{det}[X] + Y_{X/D} \mu_m[X] \left( \frac{[D]}{K_D + [D]} \right) \left( \frac{[A]}{K_A + [A]} \right) \]

\[ -K_e[\tilde{X}] \]

\[ \text{............... (7.4)} \]

The conceptual model used here for representing attached bacteria cells is similar to the macroscopic model described by Baveye and Valocchi (\textit{Wat. Resour. Res.}, 25, 1413-1421,1989). The model also assumes first-order kinetic expressions for representing bacterial attachment and detachment processes (Taylor and Jaffe, \textit{Wat. Resour. Res.}, 26, 2181-2194,1990, and Hornberger et al., \textit{Wat. Resour. Res.}, 28, 915-938, 1992). Permeability and porosity changes caused by bacterial growth are ignored in this formulation. However, if required, macroscopic models for biomass-affected porous-media properties described by Clement et al. (\textit{Ground Water}, 34, 934-942, 1996) may be integrated within this modeling approach. It should be noted that a lot of active research is currently underway to gain an increased understanding of bacteria transport in porous media because currently available bacterial transport models (including the model used here) are arguably approximate. Therefore, application of this model to real situations should be always supported by field- or laboratory-scale data.

The reactive-transport model discussed above was set-up as a \textit{RT3D} reaction package with three mobile species (to represent electron donor, electron acceptor, and aqueous bacteria) and one immobile species (to represent attached soil bacteria). After employing the reaction-operator splitting strategy, the reaction package for the problem reduces to:

\[ \frac{d[D]}{dt} = \frac{\mu_m}{R_D} \left( [X] + \frac{\rho \tilde{X}}{\phi} \right) \left( \frac{[D]}{K_D + [D]} \right) \left( \frac{[A]}{K_A + [A]} \right) \]

\[ \text{............... (7.5)} \]

\[ \frac{d[A]}{dt} = \frac{Y_{A/D} \mu_m}{R_A} \left( [X] + \frac{\rho \tilde{X}}{\phi} \right) \left( \frac{[D]}{K_D + [D]} \right) \left( \frac{[A]}{K_A + [A]} \right) \]

\[ \text{............... (7.6)} \]
The problem we will be solving in this tutorial is similar to the problem described in the first tutorial (Figure 2.1). The site is a 510 m X 310 m section of a confined aquifer with a flow gradient from left to right. An underground storage tank is leaking fuel hydrocarbon contaminants at 2 m$^3$/day at the location shown. Source concentration of BTEX is 500 mg/L. It will be assumed that the aquifer is initially clean and has very low levels of aerobic bacterial activity. The fuel hydrocarbon compounds are expected to serve as the carbon source, resuscitating the bacterial cells and activating them into a growth mode. This is a common subsurface phenomenon that occurs in most fuel-contaminated sites. Several field studies have observed the presence of enhanced levels of microbial activity near a source region, and low background levels outside the plume. In this example, we will simulate the transient changes in hydrocarbon, oxygen, and bacterial concentrations levels within the contaminated area.

Initial levels of hydrocarbon, oxygen, aqueous bacteria, and attached bacteria are assume to be: 0.0 mg/L, 9.0 mg/L, $2 \times 10^{-17}$ (value for $X$ in mg/L), and $3.0 \times 10^{-9}$ (value for $X_\sim$ in mg of bacteria/mg of soil), respectively. Note the mass fraction unit used for representing soil bacterial cells will always yield small numbers. Using the value of soil porosity and bulk density, these numbers can be converted into standard mg/L units (liquid-volume basis) to get a better feel for bacterial concentration levels. For example, assuming $\rho = 1.6 \times 10^6$ mg/L and $\phi = 0.3$, the initial value of soil bacterial concentration can be expressed (converted to liquid volume basis using the formula: $X_\sim \rho/\phi$) as: 0.016 mg/L. While post processing output concentration in GMS, the data calculator will be used to perform this unit conversion. This is recommended because extremely small numbers may not be displayed correctly in GMS.

Assumed values for other kinetic reaction constants are given below:
<table>
<thead>
<tr>
<th>Constant</th>
<th>GMS Display</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \mu_m )</td>
<td>umax</td>
<td>0.125 day(^{-1} )</td>
</tr>
<tr>
<td>( K_A )</td>
<td>( K_{ed} )</td>
<td>0.12 mg/L</td>
</tr>
<tr>
<td>( K_A )</td>
<td>( K_{ea} )</td>
<td>0.1 mg/L</td>
</tr>
<tr>
<td>( Y_{x,D} )</td>
<td>( Y_{x,ed} )</td>
<td>0.05</td>
</tr>
<tr>
<td>( Y_{x,D} )</td>
<td>( Y_{x,ea} )</td>
<td>3.0</td>
</tr>
<tr>
<td>( K_{decay} )</td>
<td>( K_{decay} )</td>
<td>0.001 day(^{-1} )</td>
</tr>
<tr>
<td>( K_{at} )</td>
<td>( K_{at} )</td>
<td>70.0 day(^{-1} )</td>
</tr>
<tr>
<td>( K_{det} )</td>
<td>( K_{det} )</td>
<td>1.0 day(^{-1} )</td>
</tr>
</tbody>
</table>

Sorption is assumed to be negligible for this site, hence the value of all retardation coefficients are assumed to be unity.

The first part of the problem will be to import a previously computed MODFLOW flow model of the site. Using this flow field, a reactive transport model will be then be defined using RT3D.

### 7.3 Launching GMS

Before launching GMS, you should have installed GMS. If you have not yet installed GMS, please do so before continuing.

To launch the PC version of GMS:

Select the GMS shortcut from the Programs section in the Start menu (Windows 95, Windows NT 4.0), or double-click on the GMS icon in the GMS program group (Windows 3.1).

To launch the Unix version of GMS:

1. Bring up an xterm window.
2. Change to the directory containing the GMS executable.
3. Type `gms` at the command line.

### 7.4 Required Modules/Interfaces

This tutorial utilizes the following components of the GMS interface:

- The 3D Grid module
- The MODFLOW interface
- The RT3D interface
You can confirm whether each of these components has been enabled on your copy of GMS by selecting the Register command from the File menu. If you have licensed and enabled each of the listed items on your version of GMS, you can proceed to complete the tutorial in normal mode. If not, you will need to obtain an updated password or hardware lock before continuing.

### 7.5 Importing the MODFLOW Model

The first part of the simulation is to import the MODFLOW flow model. A steady state flow model has been previously computed and is supplied with the tutorial files.

1. Switch to the 3D Grid Module.
2. Select the Read Simulation command in the MODFLOW menu.
3. In the Open dialog, locate and open the file entitled gms/tutorial/rt3d/flowmod/flowmod1.mfs.

At this point, you should see a grid appear.

### 7.6 Building the Transport Model

Now that the flow model is imported, the next step is to perform the RT3D simulation. For this part of the simulation, we will select the reaction, define the reaction data, define the supplemental layer data needed by RT3D, define the boundary conditions, and assign concentrations to the well.

### 7.7 The BTN Package

The first step is to initialize the data in the Basic Transport Package. First, we will initialize the data, select RT3D as the transport model, and select the appropriate packages.

1. Select the Basic Transport Package command from the MT3D/RT3D menu.
2. Select the New button.
3. In the Units section, enter $d$ for the time units, $ft$ for the length units, and $lb$ for the mass units.
4. Select the RT3D option.
5. Select the Packages button.

6. Select the Advection Package, the Source/Sink Mixing Package, the Dispersion Package, and the Chemical Reaction Package.

7. For the reaction type, select the Double Monod Model option.

8. Select the OK button to exit the Packages dialog.

Note that in the Starting Concentration section of the dialog, the species associated with the reaction we are modeling are listed by name. The next step is to define the starting concentration for each of these species. The default starting concentration is zero. We will use the default value for the electron donor, but we will use non-zero values for the electron acceptor (9.0 mg/L), the aqueous phase bacteria (2x10^{-17} mg/L), and the solid phase bacteria (3x10^{-9} mg bacteria/mg of soil).

1. Select Electron Acceptor from the list of species.

2. Select the Starting Conc.'s button.

3. Select the Constant -> Grid button.

4. Enter a value of 9.0.

5. Select the OK button.

6. Select the OK button to exit the Starting Concentration dialog.

7. Repeat these steps to enter a starting value of 2e-17 for the Aqueous-Phase Bacteria and 3e-9 for the Solid-Phase Bacteria.

Next, we will define the layer parameters. The aquifer is a uniform horizontal aquifer with a top elevation of 10 m, a thickness of 10 m, and a porosity of 0.3.

1. Select the HTOP button.

2. Select the Constant -> Grid button.

3. Enter a value of 10 and select OK.

4. Select the OK button to exit the HTOP dialog.

5. Select the Thickness button.

6. Select the Constant -> Grid button.

7. Enter a value of 10 and select OK.
8. Select the OK button to exit the Thickness dialog.

9. Select the Porosity button.

10. Select the Constant -> Grid button.

11. Enter a value of 0.3 and select OK.

12. Select the OK button to exit the Porosity dialog.

Next, we will define the stress periods. Since the injection rate and the boundary conditions do not change, we will use a single stress period with a length of 730 days (two years).

1. Select the Stress Periods button.

2. Enter a value of 730 for the Length.

3. Enter a value of 10 for the No. of time steps.

4. Select the OK button to exit the Stress Periods dialog.

Finally, we will define the output options. One binary solution file is created by RT3D for each of the species. By default, RT3D saves a solution at each transport step for each species. Since this results in large files containing more solutions than we need for the simple post-processing we intend to do, we will specify that a solution be saved every 73 days (every time step).

1. Select the Output Control button.

2. Select the Print at specified times button.

3. Select the Times button.

4. Select the Initialize Values button.

5. Enter 73.0 for the Initial time step size.

6. Enter 73.0 for the Maximum delta time step.

7. Enter 730.0 for the Maximum simulation time.

8. Select the OK button to exit the Variable Time Steps dialog.

9. Select the OK button to exit the Output Control dialog.

This completes the input for the Basic Transport package.

Select the OK button to exit the Basic Transport Package dialog.
### 7.8 Assigning Concentrations to the Left Boundary

The left boundary of the model is a constant head boundary. Since the head at the left boundary is greater than the head at the right boundary, the left boundary acts as a source and water enters the model from the left. Thus, we must define the concentrations of our species at the left boundary. The simplest way to do this is to mark the cells as specified concentration cells.

1. Select the *Select Cell* tool.
2. Select the cells on the left boundary by dragging a box that just surrounds the cells.
3. Select the *Cell Attributes* command in the MT3D/RT3D menu.
4. Change the *ICBUND* value to –1.
5. Select the *OK* button.

### 7.9 The Advection Package

The next step is to initialize the data for the Advection package. Select the *Method of characteristics* option and accept the default settings.

### 7.10 The Dispersion Package

Next, we will enter the data for the Dispersion package. The aquifer has a longitudinal dispersivity of 10.0 m and a transverse (horizontal) dispersivity of 3.0 m. The vertical dispersivity is assumed equal to the longitudinal dispersivity.

1. Select the *Dispersion Package* command in the MT3D/RT3D menu.
2. Select the *Longitudinal Dispersivity* button.
3. Select the *Constant -> Grid* button.
4. Enter a value of 10.0 and select *OK*.
5. Select the *OK* button to exit the *Longitudinal Dispersivity* dialog.
6. Enter a value of 0.3 for the *Ratio of the transverse dispersivity to long. dispersivity* value.
7. Select the *OK* button to exit the *Dispersion Package* dialog.
7.11 The Source/Sink Mixing Package

Next, we will initialize the Source/Sink Mixing package and define the concentration at the spill location. We will assign a concentration of 500 mg/L for the electron donor and leave the other concentrations at the default value of 0.0.

1. Select the Source/Sink Mixing Package command in the MT3D/RT3D menu.

2. In the Initialize Point Source/Sinks from MODFLOW section in the lower right corner of the dialog, select the Well button.

3. Using the horizontal scroll bar below the spreadsheet section, scroll over until the Electron Donor column is visible.

4. Change the Electron Donor value to 500.0.

5. Select the OK button to exit the Source/Sink Mixing Package dialog.

7.12 The Chemical Reaction Package

Next, we will initialize the chemical reaction package and define appropriate reaction rate constants.

1. Select the Chemical Reaction Package command in the MT3D/RT3D menu.

2. In the Reaction Parameters section, click on the umax item and set its value to 0.125.

3. Likewise, set the value of Yea/ed to 3.0.

The rest of the constants will all be left at the default values.

Select the OK button.

7.13 Running RT3D

At this point, we are ready to save the model and run RT3D.

1. Select the Save Simulation command from the MT3D/RT3D menu.

2. At the top of the dialog, enter "bacteria" for the prefix.

3. To the right of the prefix, select the Update button.
4. At the top of the dialog, select the File Browser button.

5. In the Save File dialog, locate and open the directory entitled gms/tutorial/rt3d/monod/.

6. Select the Save button to exit the Save File dialog.

7. Select the OK button to save the files.

To run RT3D:

1. Select the Run RT3D command from the MT3D/RT3D menu.

2. Select OK at the prompt.

3. When the simulation is finished, close the window and return to GMS.

7.14 Viewing the Results

Now, we will read in the concentration files and view the results.

1. Select the Open command from the File menu.

2. Select and open the file titled "bacteria.dss".

3. Select the Data Browser command in the Data menu.

7.14.1 Electron Donor

First, we will view the Electron Donor solution at 730 days.

1. Select the Electron Donor data set.

2. Scroll down and select the time step at t=730 days.

3. Select the Done button to exit the Data Browser.

To display the concentration contours:

1. Select the Display Opts command in the Display menu.

2. Turn on the Layer contours option.

3. Select the OK button.

To display color-filled contours:
1. Select the Contour Opts command in the Data menu.

2. Turn on the Color fill between contours option.

3. Select the OK button.

Recall that the electron donor solution represents the contaminant. The plume is moving from the left to the right side, as expected.

7.14.2 Electron Acceptor

Next, we will view the electron acceptor solution.

1. Select the Data Browser command in the Data menu.

2. Select the Electron Acceptor data set.

3. Scroll down and select the time step at t=730 days.

4. Select the Done button to exit the Data Browser.

Note that the electron acceptor solution is the inverse of the electron donor solution. The minimum value (the blue region) corresponds to the location of the plume.

7.14.3 Aqueous-Phase Bacteria

Next, we will view the solution for the aqueous-phase bacteria.

1. Select the Data Browser command in the Data menu.

2. Select the Electron Acceptor data set.

3. Scroll down and select the time step at t=730 days.

4. Select the Done button to exit the Data Browser.

Note that the bacteria are flourishing at the left end and around the edges of the plume where there is a combination of electron donors and electron acceptors.

7.14.4 Solid-Phase Bacteria

Finally, we will view the solid-phase bacteria. However, before viewing the data set, we need to adjust the data set. The mass fraction unit used for representing soil bacterial cells (mg of bacteria/mg of soil) always yields small numbers. The resulting concentrations are so small that they sometimes
produce numerical round-off errors in the GMS contouring routines. Thus, we will first utilize the Data Calculator to convert to units of mg/L. For example, assuming $\rho = 1.6 \times 10^6$ mg/L and $\phi = 0.3$, the initial value of soil bacterial concentration can be converted to liquid volume basis using the formula: $X = \frac{\rho}{\phi}$.

1. Select the Data Calculator command from the Data menu.

2. Enter "e*(1.6*10^6)/0.3" in the Expression field (the Soil-Phase Bacteria data set should be listed as item e).

3. Enter "Soil Bacteria" in the Result field.

4. Select the Compute button.

5. Select the Done button.

Note that the distribution of the soil bacteria is similar to the distribution of the aqueous-phase bacteria.

### 7.14.5 Other Post-Processing Options

At this point, you may wish to experiment with the other post-processing options, including film loop animation and time series plots.

### 7.15 Conclusion

This concludes the tutorial: Double Monod Model. If you wish to exit GMS at this time:

1. Select the Exit command from the File menu.

2. Select the OK button at the prompt.